从键盘输入n(n<20)个学生的姓名(不超过20个字符)及4门课的成绩,求每个学生4门课的总分并输出。
提示:用结构体数组实现。部分代码如下:
#include<stdio.h>
typedef struct stu {
char name[20];
float score[4];
} STU;
int main()
{
int i, j, n;
STU stu[20];
......
......
return 0;
}
输入格式:
学生人数n
学生姓名及4门课的成绩,成绩可以有小数点。
输出格式:
学生姓名:总分
其中学生姓名和总分之间用“:”隔开,总分保留两位小数。
每个学生的数据占一行。
输入样例:
3
a 4 5 6 7
b 7 2 1 3
c 8 4 2 3
输出样例:
a:22.00
b:13.00
c:17.00
示例:
#include <stdio.h>
#include<stdlib.h>
typedef struct stu {
char name[20];
float score[4];
} STU;
int main()
{
int i, j, n;
STU stu[20];
int sum[3]={0,0,0};
/*输入n */
scanf("%d\n",&n);
for(i=0;i<n;i++)
{
scanf("%s %d %d %d",stu[i].name,&stu[i].score[0],&stu[i].score[1],&stu[i].score[2]);
sum[0]+=stu[i].score[0];
sum[1]+=stu[i].score[1];
sum[2]+=stu[i].score[2];
/*累加各科学生总成绩*/
for(i=0;i<n;i++)
{
printf("%c:%.3f\n",stu[i].name,&sum[i]);
}
return 0;
}
}
//这个当时我PTA上没通过,老师关闭了提交通道,现在也不知道改了之后对不对,如果有错误,还请读者告诉我,不胜感激