【ACM】Uva 1152 (4 Values whose Sum is 0) 二分查找lower_bound() 和upper_bound()的使用

【问题描述】

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d) ∈ A × B × C × D are such that a + b + c + d = 0. In the following, we assume that all lists have the same size n.

【输入描述】

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs. The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228) that belong respectively to A, B, C and D.

【输出描述】

For each test case, your program has to write the number quadruplets whose sum is zero. The outputs of two consecutive cases will be separated by a blank line.

【样例输入】

1

6

-45 22 42 -16

-41 -27 56 30

-36 53 -37 77

-36 30 -75 -46

26 -38 -10 62

-32 -54 -6 45

【样例输出】

5

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46), (-32, 30, -75, 77), (-32, -54, 56, 30).

 

题目大意就是从四列中分别选出一个数,然后这四个数相加的和为0,暴力的话肯定会超时。

把c[n]和d[n]求和存放到cd[n*n]中并排序,再看 -(a[i]+b[j]) 是否存在于cd[n*n]中。

也可以将a[i]+b[j]放入一个数组ab[n*n]中。

可以使用upper_bound()和lower_bound()函数查找。

参考链接:关于lower_bound( )和upper_bound( )的常见用法

时间:2020ms

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int maxn = 4010;
int a[maxn],b[maxn],c[maxn],d[maxn],cd[maxn*maxn],ab[maxn*maxn];

int main()
{
	int  i,j,T,n,cnt,t,k;
	scanf("%d",&T);
	while(T--)
	{
		k=0;
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%d%d%d%d",&a[i],&b[i],&c[i],&d[i]);
		}
		for(i=0;i<n;i++)
		{
			for(j=0;j<n;j++)
			{
				cd[k]=c[i]+d[j];
				ab[k++]=a[i]+b[j];
			}
		}
		sort(cd,cd+k);
		sort(ab,ab+k);
		cnt=0;
		for(i=0;i<k;i++)
		{
			cnt+=(upper_bound(cd,cd+k,-ab[i])-lower_bound(cd,cd+k,-ab[i]));
		}
		printf("%d\n",cnt);
		if(T)
			printf("\n");
	}
	return 0;
}

 

时间:2530ms

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int maxn = 4010;
int a[maxn],b[maxn],c[maxn],d[maxn],cd[maxn*maxn];

int main()
{
	int  i,j,T,n,cnt,t,k;
	scanf("%d",&T);
	while(T--)
	{
		k=0;
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%d%d%d%d",&a[i],&b[i],&c[i],&d[i]);
		}
		for(i=0;i<n;i++)
		{
			for(j=0;j<n;j++)
			{
				cd[k++]=c[i]+d[j];
			}
		}
		sort(cd,cd+k);
		cnt=0;
		for(i=0;i<n;i++)
		{
			for(j=0;j<n;j++)
			{
				t=-(a[i]+b[j]);
				cnt+=(upper_bound(cd,cd+k,t)-lower_bound(cd,cd+k,t));
			}
		}
		printf("%d\n",cnt);
		if(T)
			printf("\n");
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值