HDU 1005 Number Sequence解题报告

Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n – 1) + B * f(n – 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

 Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed. 

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5 

这个题模7 所以fn 只可能是0 1 2 3 4 5 6,就这么几个数,肯定会循环的,所以找规律吧。。。

#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
	int fn1=1,fn2=1,f3=0;
	int a,b,n,i,result;
	while(scanf("%d%d%d",&a,&b,&n)!=EOF)
	{
		fn1=1;
		fn2=1;
		if(a+b+n==0)
		{
			break;
		}
		if(n==1||n==2)
		{//n=1和n=2的时候fn当然是=1,撤。。。
			printf("1\n");
			continue;
		}
		else if(n>2&&n<=1000)
		{//小于1000的时候就不找规律了吧,,,一千,暴力,完了,撤。。。
			for(i=3;i<=n;i++)
			{
				f3=(a*fn1+b*fn2)%7;
				fn2=fn1;
				fn1=f3;
			}
			result=f3;
		}
		else 
		{
			for(i=3;i<=10000;i++)
			{
				f3=(a*fn1+b*fn2)%7;
				if(f3==1&&fn1==1)//大与一千,就找循环了,找到了就简单了吧。
				{
					break;
				}
				fn2=fn1;
				fn1=f3;
 
			}
			//printf("%d %d\n",f3,fn1);
			n=(n-2)%(i-2);//终于找到了
			fn1=1;
			fn2=1;
			if(n==0)
			{
				printf("1\n");
			}
			else
			for(i=1;i<=n;i++)
			{
				f3=(a*fn1+b*fn2)%7;
				fn2=fn1;
				fn1=f3;
			}
			result=f3;
		}
		printf("%d\n",result);
	}
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值