HDU 1018 Big Number数论(解题报告)

Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 Sample Input
2
10
20
 Sample Output
7
19
额。。。。一道数学题,还是很有意思的,受益了。
两种解法。
解法一:
   首先看一个数:1234567 很明显它是7位吧,然后我们会发现,10^6<1234567<10^7;
所以咱们就想到了对数了们可以得出 log10(1234567)=6.091514  设m = 6.091514 那么(int)m = 6 m+1就是答案了。
#include<iostream>
#include<math.h>
#include<stdio.h>
using namespace std;
int main()
{
	int n,t;
	double sum;
	scanf("%d",&t);
	while(t--)
	{
		sum=0;
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		{
			sum+=log10(i);
		}
		printf("%d\n",(int)(sum+=1));
	}
	return 0;
} 

解法二:
   利用数学公式:斯特林公式:ln(N!) = Nln(N)-N + 0.5*ln(2*N*pi)
                                 还有对数换底公式啊:loge(N)/loge(10)=log10(N);
#include<iostream>
#include<stdio.h>
#include<math.h>
#define pi 3.141592654
using namespace std;
int main()
{
	int n,t;
	double sum;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		double temp=(n*log(n)-n+0.5*log(2*n*pi))/log(10);
		printf("%d\n",(int)temp+1);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值