hdu 1005 Number Sequence(思维题)

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 

#include <iostream>//我想说的是这个人很聪明1 1 n的周期是16,,1 2 n的周期是6
using namespace std;//1 3 n的周期是24 ,我这个三个数是48的因子,当我知道周期
int main()//变化,我就不知道该怎么做了,看了别人的代码后,才想起可以这样本来我是想暴力的
{
    int a[50]= {1,1},A,B,n;
    while(cin>>A>>B>>n)
    {
        if(A==0&&B==0&&n==0)break;
        if(A==7&&B==7)
        {
            printf("0\n"); continue;
        }
        else if(n>2)
        {
            for(int i=2; i<=(n-1)%48; i++)
                a[i]=(A*a[i-1]+B*a[i-2])%7;
        }
        cout<<a[(n-1)%48]<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值