How do you add?------组合数学,隔板

Larry is very bad at math — he usually uses a calculator, which
worked well throughout college. Unforunately, he is now struck in
a deserted island with his good buddy Ryan after a snowboarding
accident.
They’re now trying to spend some time figuring out some good
problems, and Ryan will eat Larry if he cannot answer, so his fate
is up to you!
It’s a very simple problem — given a number N, how many ways
can K numbers less than N add up to N?
For example, for N = 20 and K = 2, there are 21 ways:
0+20
1+19
2+18
3+17
4+16
5+15
...
18+2
19+1
20+0
Input
Each line will contain a pair of numbers N and K. N and K will both be an integer from 1 to 100,
inclusive. The input will terminate on 2 0’s.
Output
Since Larry is only interested in the last few digits of the answer, for each pair of numbers N and K,
print a single number mod 1,000,000 on a single line.
Sample Input
20 2
20 2
0 0
Sample Output
21

21

题目大意:大小为n的数分成m组有多少种

题意:给你n和k,让n分成K组(可以为0);插板法,把n看成n个1,因为可以为0,所以还要加上k个0!!!,即 1 1 1 1 .............0 0 0 0,然后共有n+k-1个空,插入k-1个板.

C(n-k+1,k-1)

隔板法........:

https://baike.baidu.com/item/%E9%9A%94%E6%9D%BF%E6%B3%95/3902458?fr=aladdin

 

#include<stdio.h>
#include<algorithm>
#define mod 1000000
using namespace std;
typedef long long ll;
int main()
{
    ll n,k,i,j,c[300][300];
    c[0][0]=1;c[1][0]=1;c[1][1]=1;
    for(i=2;i<200;i++)
    {
        c[i][0]=1;c[i][i]=1;
        for(j=1;j<i;j++)
        {
            c[i][j]=(c[i-1][j]+c[i-1][j-1])%mod;
        }

    }
    while(~scanf("%lld%lld",&n,&k))
    {
        if(n==0&&k==0)
         continue;
        printf("%lld\n",c[n+k-1][k-1]);
    }
    return 0;
}

 2.???

用d(i,j)表示i拆成j个数和的种类数

d(i,j)=d(i-1,j)+d(i,j-1)

边界:d(i,1)=1

#include <stdio.h>
#include <string.h>
#define mod 1000000
int main()
{
    int p[110][110],n,k;
    memset(p,0,sizeof(p));
    for(int i=0;i<=100;i++)
    {
        p[i][1]=1;
        for(int j=2;j<=100;j++)
        {
            p[i][j]=(p[i-1][j]%mod+p[i][j-1]%mod)%mod;
        }
    }
    while(scanf("%d%d",&n,&k)==2)
    {
        if(!n&&!k)break;
        printf("%d\n",p[n][k]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值