How do you add?(dp)

题目:
Larry is very bad at math — he usually uses a calculator, which
worked well throughout college. Unforunately, he is now struck in
a deserted island with his good buddy Ryan after a snowboarding
accident.
They’re now trying to spend some time figuring out some good
problems, and Ryan will eat Larry if he cannot answer, so his fate
is up to you!
It’s a very simple problem — given a number N, how many ways
can K numbers less than N add up to N?
For example, for N = 20 and K = 2, there are 21 ways:
0+20
1+19
2+18
3+17
4+16
5+15

18+2
19+1
20+0
Input
Each line will contain a pair of numbers N and K. N and K will both be an integer from 1 to 100,
inclusive. The input will terminate on 2 0’s.
Output
Since Larry is only interested in the last few digits of the answer, for each pair of numbers N and K,
print a single number mod 1,000,000 on a single line.
Sample Input
20 2
20 2
0 0
Sample Output
21
21
思路理解(大神勿喷,本人菜鸟):就是输入两个数字N,K。要求是把N分为K个数有多少种分法;我想到是dp把dp【100】【100】内的数目存好。然后我自己在草稿本上画了一个图,验证了一下。是上传了我的代码,AC了。

就是这个图
下面是代码,这个图我得到了递推公式(在代码里面);

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <cmath>
#include <algorithm>
long dp[105][105];
using namespace std;
int main()
{
    int N,K;
    for(int  i=0;i<101;i++)
    {
        dp[0][i]=0;
        dp[i+1][0]=1;
    }
    for(int i=1;i<101;i++)
        for(int j=1;j<101;j++)
    {
        dp[i][j]=(dp[i-1][j]+dp[i][j-1])%1000000;
    }
    while(cin>>N>>K)
    {
        if(N==0&&K==0)
            exit(0);
        cout<<dp[K][N]<<endl;
    }
        return 0;
}
最后声明,我是菜鸟,不要喷,
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值