邮票

邮票

Description

邮局发行一套票面有n(0<n<=10)种不同面值的邮票。若限每封信所贴的邮票张数不得超过m枚,存在整数r使得用不超过m(0<m<=2n)枚的邮票,可以贴出连续整数1,2,3,…,r值来,找出这种面值数,使得r值最大。

Input

一行,输入N及M

Output

输出R

Sample Input

2 3

Sample Output

7

Source

搜索,回溯

Sulotion

枚举搜索选择的邮票面值,每一次确定一个面值后,就用他更新当前的最大数

    for (int j = 1; j <= x; ++j)
      if (ch >= a[j] && b[ch] > b[ch - a[j]] + 1) b[ch] = b[ch - a[j]] + 1;

Code

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stack>
#include <map>
#include <vector>
#include <queue>
#define L 1001
#define inf 127
#define LL long long
using namespace std;

int n, m, a[50], b[L], ans, cnt, ch, r, bj;

inline int find(int x) {
  memset(b, inf, sizeof(b)), b[0] = 0, ch = 0;
  while (1) {
    ch++;
    for (int j = 1; j <= x; ++j)
      if (ch >= a[j] && b[ch] > b[ch - a[j]] + 1) b[ch] = b[ch - a[j]] + 1;
    if (b[ch] > m) return ch - 1;
  }
}

inline void dfs(int x) {
  if (x == n + 1) {ans = max(ans, cnt); return ;}
  for (int i = a[x - 1] + 1; i <= cnt + 1; ++i) 
    a[x] = i, cnt = find(x), dfs(x + 1);
}

int main() {
  freopen("2221.in", "r", stdin);
  freopen("2221.out", "w", stdout);
  a[1] = 1;
  scanf("%d %d", &n, &m), cnt = m;
  dfs(2);
  printf("%d\n", ans);
  return 0;
}

Summary

第一次写了个什么剪枝都没有的搜索,最后T了几秒中

第二次加了几个不像剪枝的剪枝,但是一直RE,查了好久才发现b数组开太大了??!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值