ACM-ICPC 2018 焦作赛区网络预赛-K-Transport Ship

12 篇文章 0 订阅

There are NN different kinds of transport ships on the port. The i^{th}ith kind of ship can carry the weight of V[i]V[i] and the number of the i^{th}ith kind of ship is 2^{C[i]} - 12C[i]−1. How many different schemes there are if you want to use these ships to transport cargo with a total weight of SS?

It is required that each ship must be full-filled. Two schemes are considered to be the same if they use the same kinds of ships and the same number for each kind.

Input

The first line contains an integer T(1 \le T \le 20)T(1≤T≤20), which is the number of test cases.

For each test case:

The first line contains two integers: N(1 \le N \le 20), Q(1 \le Q \le 10000)N(1≤N≤20),Q(1≤Q≤10000), representing the number of kinds of ships and the number of queries.

For the next NN lines, each line contains two integers: V[i](1 \le V[i] \le 20), C[i](1 \le C[i] \le 20)V[i](1≤V[i]≤20),C[i](1≤C[i]≤20), representing the weight the i^{th}ith kind of ship can carry, and the number of the i^{th}ith kind of ship is 2^{C[i]} - 12C[i]−1.

For the next QQ lines, each line contains a single integer: S(1 \le S \le 10000)S(1≤S≤10000), representing the queried weight.

Output

For each query, output one line containing a single integer which represents the number of schemes for arranging ships. Since the answer may be very large, output the answer modulo 10000000071000000007.

样例输入复制

1
1 2
2 1
1
2

样例输出复制

0
1

地址:https://nanti.jisuanke.com/t/31720

思路:多重背包即可。。。

Code:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;

const int MOD=1000000007;
const int MAX_N=25;
const int MAX_S=10005;
int n,Q,T;
int V[MAX_N],C[MAX_N];
int dp[MAX_S];

int main()
{
	scanf("%d",&T);
	while(T--){
		memset(dp,0,sizeof(dp));
		scanf("%d%d",&n,&Q);
		for(int i=1;i<=n;++i)
			scanf("%d%d",&V[i],&C[i]);
		for(int i=1;i<=n;++i)
			C[i]=pow(2,C[i])-1;
		dp[0]=1;
		for(int i=1;i<=n;++i)
		{
			int k=1,vv=C[i];
			while(k<vv){
				vv-=k;
				int vi=k*V[i];
				for(int j=MAX_S-vi-1;j>=0;--j)
					if(dp[j])	dp[j+vi]=(dp[j+vi]+dp[j])%MOD;
				k*=2;
			}
			vv*=V[i];
			for(int j=MAX_S-vv-1;j>=0&&vv;--j)
				if(dp[j])	dp[j+vv]=(dp[j+vv]+dp[j])%MOD;
		}
		int x;
		while(Q--){
			scanf("%d",&x);
			printf("%d\n",dp[x]);
		}
	}
	
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值