1001 A+B Format

该篇文章介绍了如何使用C++编程语言处理输入的两个整数,按照每三位用逗号分隔的标准格式计算并输出它们的和。作者通过示例和代码展示了如何判断和的位数并进行适当的格式转换。
摘要由CSDN通过智能技术生成

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

本来是想写完乙级再写甲级的,但是今天师哥说的话也有道理,还是甲级和乙级一块儿写吧 ,正好练练英语,只不过甲级更新的速度可能要慢一下,只能说,慢慢来吧


思路:

题目的大体意思就是输入两个整数,以标准化形式输出,标准化形式也就是指每三位一个“,”,实在不理解题意的可以打开电脑上的计算器模拟一下。根据数据范围,可以知道,答案中最多出现两个“,”情况,所以直接枚举没有“,”的情况,只有一个的情况以及只有两个的情况就ok了


C++

#include <iostream>
#include <cstring>
using namespace std;
int main()
{
    int a, b;
    cin >> a >> b;
    int sum = a + b;
    if (sum < 0)
    {
        cout << "-";
        sum *= -1;
    }
    string s = to_string(sum);
    if (s.size() > 6)
        cout << s.substr(0, s.size() - 6) << "," << s.substr(s.size() - 6, 3) << "," << s.substr(s.size() - 3) << endl;
    else if (s.size() > 3)
        cout << s.substr(0, s.size() - 3) << "," << s.substr(s.size() - 3) << endl;
    else
        cout << s << endl;
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值