SDUT 2192救基友记2

救基友记2

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description
    屌丝 WP 的好基友 CZ 又被妖鬼给抓走了( CZ 啊, CZ…. 怎么说你好呢 . 吃着锅里想着碗里),为了求出 CZ ,他只好去求高富帅 RQ, RQ WP 出了到题目说只要你能解决这道题目,他就答应帮屌丝 WP 去解救好基友 CZ 。题目描述如下:
  给你一个字符串s,长度小于1000,让你找出该字符串所包含的所有子串"cRazY" 或者"CraZy",并将找出的子串的大写字母变成小写字母,小写字母变成大写字母,然后输出该字符串。
  “好基友,一被子” 你作为WP的好基友,能帮他解决这个问题吗?
Input
  1 行是一个整数 T ,表示测试数据的个数( 1<=T<=10 )。接下来有 T 组测试数据。

每组测试数据包括包括一个字符串s

Output
  输出 T 行,表示转换后的字符串 
Example Input
2
abjbjhcRazYdcRazYCraZy
bbbnnnbbn
Example Output
abjbjhCrAZydCrAZycRAzY
bbbnnnbbn
import java.io.BufferedInputStream; 
import java.text.ParseException; 
import java.text.SimpleDateFormat; 
import java.util.Locale; 
import java.util.Scanner; 
import java.util.logging.Level; 
import java.util.logging.Logger; 

public class Main {
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		String str1 = "cRazY";
		String str2 = "CraZy";
		String newstr1 = "CrAZy";
		String newstr2 = "cRAzY";
		int count = sc.nextInt();
		for(int i = 0 ; i< count ; i++) {
			String str = sc.next();
			System.out.println(replace(str,str1,newstr1,str2,newstr2));
		}
	}

	private static String replace(String str, String str1, String newstr1,
			String str2, String newstr2) {
		str = str.replaceAll(str1, newstr1);
		str = str.replaceAll(str2, newstr2);
		return str;
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值