The Dole Queue(c语言)

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros
Party has decided on the following strategy. Every day all dole applicants will be placed in a large
circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter
clockwise up to N (who will be standing on 1’s left). Starting from 1 and moving counter-clockwise,
one labour official counts off k applicants, while another official starts from N and moves clockwise,
counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick
the same person she (he) is sent off to become a politician. Each official then starts counting again
at the next available person and the process continues until no-one is left. Note that the two victims
(sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already
selected by the other official.
Input
Write a program that will successively read in (in that order) the three numbers ( N , k and m ; k, m > 0 ,
0 < N < 20 ) and determine the order in which the applicants are sent off for retraining. Each set of
three numbers will be on a separate line and the end of data will be signalled by three zeroes ( 0 0 0 ).
Output
For each triplet, output a single line of numbers specifying the order in which people are chosen. Each
number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter
clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a
trailing comma).
Note: The symbol in the Sample Output below represents a space.
Sample Input
10 4 3
0 0 0
Sample Output
␣␣4␣␣8,␣␣9␣␣5,␣␣3␣␣1,␣␣2␣␣6,␣10,␣␣7
#include<stdio.h>
#include<string.h>
int main()
{
	int n, m, k;
	int a[100] = { 0 }, book[100] = { 0 };
	while (scanf("%d%d%d", &n, &m, &k) && n && m && k)
	{
		memset(book, 0, sizeof(book));

		int head = 1;
        //表示第一个official开始数人的开头,起始是从第一个人开始数
		int end = n;
        //表示第二个official开始数人的开头,也就是最后一个
		int temp = n;

		while (temp != 0)
		{
			int num = 0;
			int t1, t2;
            //开始第一个official的循环
			for (int i = head;i <= n;i++)
			{
				if (book[i] == 0)
				{
					num++;
					if (num == m)//以m为一个周期
					{
						t1 = i;
						num = 0;
                        //循环完成,要有好的习惯,将其归零
						break;
					}
				}
				if (i == n)
				{
					i = 0;
				}
                //这个if语句主要是防止还没数到第m个就已经跳出循环
			}
            //开始第二个official的循环,与第一个是相同的操作,我就不在赘述了(^v^)偷个懒
			for (int i = end;i >= 1;i--)
			{
				if (book[i] == 0)
				{
					num++;
					if (num == k)
					{
						t2 = i;
						num = 0;
						break;
					}
				}
				if (i == 1)
				{
					i = n + 1;
				}
			}
            //循环结束后记得将head,end跟新为当前位置
			head = t1;
			end = t2;
            //t1,t2代表的是选出的那两个人,应在循环结束后将其的状态定为已经被选走
			book[t1] = 1;
			book[t2] = 1;
            //t1和t2相等temp只用减去一个人数,不相等则减去两个
			if (t1 == t2)
			{
				printf("%3d", t1);
				temp--;
			}
			else
			{
				printf("%3d%3d", t1, t2);
				temp -= 2;
			}
            //最后一组被选出的末尾不用加逗号
			if (temp != 0)
				printf(",");
		}
		printf("\n");
	}
	return 0;
}

用C++编写程序,实现以下问题2、题目ID Codes(POJ1146) Time Limit: 1000MS Memory Limit: 10000K 描述: It is 2084 and the year of Big Brother has finally arrived, albeit a century late. In order to exercise greater control over its citizens and thereby to counter a chronic breakdown in law and order, the Government decides on a radical measure--all citizens are to have a tiny microcomputer surgically implanted in their left wrists. This computer will contains all sorts of personal information as well as a transmitter which will allow people's movements to be logged and monitored by a central computer. (A desirable side effect of this process is that it will shorten the dole queue for plastic surgeons.) An essential component of each computer will be a unique identification code, consisting of up to 50 characters drawn from the 26 lower case letters. The set of characters for any given code is chosen somewhat haphazardly. The complicated way in which the code is imprinted into the chip makes it much easier for the manufacturer to produce codes which are rearrangements of other codes than to produce new codes with a different selection of letters. Thus, once a set of letters has been chosen all possible codes derivable from it are used before changing the set. For example, suppose it is decided that a code will contain exactly 3 occurrences of a', 2 of b' and 1 of c', then three of the allowable 60 codes under these conditions are: abaabc abaacb ababac These three codes are listed from top to bottom in alphabetic order. Among all codes generated with this set of characters, these codes appear consecutively in this order. Write a program to assist in the issuing of these identification codes. Your program will accept a sequence of no more than 50 lower case letters (which may contain repeated characters) and print the successor code if one exists or the message No Successor' if the given code is the last in the sequence for that set of characters. 输入: Input will consist of a series of lines each containing a string representing a code. The entire file will be terminated by a line consisting of a single #. 输出: Output will consist of one line for each code read containing the successor code or the words 'No Successor'. 样例输入 abaacb cbbaa # 样例输出 ababac No Successor
最新发布
05-22
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值