1023 Have Fun with Numbers java

90 篇文章 0 订阅
88 篇文章 0 订阅

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798
import java.math.BigInteger;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner scanner = new Scanner(System.in);
        String inputNum = scanner.nextLine();
        BigInteger bigIntegerNum = new BigInteger(inputNum).
                multiply(new BigInteger("2"));
        String bigString = bigIntegerNum.toString();
        int len1 = inputNum.length(), len2 = bigString.length();
        int countsInput[] = new int[20], countsBigString[] = new int[20];
        for (int i=0; i<len1; ++i) {
           char ch = inputNum.charAt(i);
           countsInput[ch-'0']++;
        }
        for (int i=0; i<len2; ++i) {
            char ch = bigString.charAt(i);
            countsBigString[ch-'0']++;
        }
        if (len1==len2) {
            boolean tag = true;
            for (int i=0; i<len1; ++i) {
                char ch = inputNum.charAt(i);
                if (countsInput[ch-'0']!=countsBigString[ch-'0']) {
                    tag = false;
                    break;
                }
            }
            if (tag) {
                System.out.println("Yes");
            } else {
                System.out.println("No");
            }
        } else {
            System.out.println("No");
        }
        System.out.println(bigString);

    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值