Ice_cream's world I

                                                  Ice_cream's world I

原题链接 http://acm.hdu.edu.cn/showproblem.php?pid=2120

ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.

Input

In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.

Output

Output the maximum number of ACMers who will be awarded. 
One answer one line.

Sample Input

8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7

Sample Output

3

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int n,m,f[1010];

void init()//初始化
{
    for(int i=0; i<=n; i++)
    {
        f[i]=i;
    }
}

int getf(int v)
{
    if(v!=f[v])
    {
        f[v]=getf(f[v]);
    }
    return f[v];
}

int merge(int u,int v)
{
    int t1=getf(u);
    int t2=getf(v);
    if(t1!=t2)//进行合并
    {
        f[t1]=t2;
        return 0;
    }
    return 1;
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        init();
        int a,b;
        int ans=0;//记录环的数量,切记清零
        for(int i=0; i<m; i++)
        {
            scanf("%d%d",&a,&b);
            ans+=merge(a,b);//merge若是环便返回1,反之为0.
        }
        printf("%d\n",ans);
    }
    return 0;
}

在王国中,要建立许多瞭望塔,瞭望塔之间的连接处有围墙。给出n个瞭望塔和各个塔之间的围墙数m。并给出m组a,b表示两者间有围墙连接,求哨塔和围墙把土地分割成了几个部分。并查集问题,并查集成环,找出环的个数便是土地的个数。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值