Coloring Brackets (区间dp)

Description

Once Petya read a problem about a bracket sequence. He gave it much thought but didn’t find a solution. Today you will face it.

You are given string s. It represents a correct bracket sequence. A correct bracket sequence is the sequence of opening (“(“) and closing (“)”) brackets, such that it is possible to obtain a correct mathematical expression from it, inserting numbers and operators between the brackets. For example, such sequences as “(())()” and “()” are correct bracket sequences and such sequences as “)()” and “(()” are not.

In a correct bracket sequence each bracket corresponds to the matching bracket (an opening bracket corresponds to the matching closing bracket and vice versa). For example, in a bracket sequence shown of the figure below, the third bracket corresponds to the matching sixth one and the fifth bracket corresponds to the fourth one.

You are allowed to color some brackets in the bracket sequence so as all three conditions are fulfilled:

Each bracket is either not colored any color, or is colored red, or is colored blue.
For any pair of matching brackets exactly one of them is colored. In other words, for any bracket the following is true: either it or the matching bracket that corresponds to it is colored.
No two neighboring colored brackets have the same color.
Find the number of different ways to color the bracket sequence. The ways should meet the above-given conditions. Two ways of coloring are considered different if they differ in the color of at least one bracket. As the result can be quite large, print it modulo 1000000007 (109 + 7).

Input

The first line contains the single string s (2 ≤ |s| ≤ 700) which represents a correct bracket sequence.

Output

Print the only number — the number of ways to color the bracket sequence that meet the above given conditions modulo 1000000007 (109+7) ( 10 9   +   7 )

Sample Input

(())
(()())
()

Sample Output

12
40
4


题意:

给你一个正确的括号序列,你可以对一些括号涂上颜色,需要满足以下条件

  • 每个括号可以不涂色,涂红色或者涂蓝色
  • 每对匹配的括号,有且仅有一个被涂色
  • 相邻的括号颜色不同

问涂色方案共有多少种?

分析:

由于给出的括号序列是正确的,故对于任意一个左括号或者右括号,与之对应匹配的括号是固定的
括号不涂色记为0,括号涂红色记为1,括号涂蓝色记为2
记当前状态 dp[i][j][x][y] d p [ i ] [ j ] [ x ] [ y ] 表示当前处理的区间为 [i,j] [ i , j ] ,并且, colori=x,colorj=y c o l o r i = x , c o l o r j = y

  • 如果 si s i sj s j 是匹配的,那么 si,sj s i , s j 的涂色方案仅有四种:01,02,10,20,并且 dp[i][j][][] d p [ i ] [ j ] [ ] [ ] 是由 dp[i+1][j1][][] d p [ i + 1 ] [ j − 1 ] [ ] [ ] 转移而来,需要满足 coloricolori+1 c o l o r i ≠ c o l o r i + 1 colorjcolorj1 c o l o r j ≠ c o l o r j − 1 ,枚举四种方案,转移方程为
    dp[i][j][x][y]+=dp[i+1][j1][p][q] d p [ i ] [ j ] [ x ] [ y ] + = d p [ i + 1 ] [ j − 1 ] [ p ] [ q ]
    x,y[1,2],p,q[0,2],px,qy 其 中 : x , y ∈ [ 1 , 2 ] , p , q ∈ [ 0 , 2 ] , p ≠ x , q ≠ y
  • 如果 si s i sj s j 不匹配,那么可以找到 k=match(i) k = m a t c h ( i ) ,即与括号 i i 相匹配的括号位置,可以将区间分解为 [i,k] [k+1,j] [ k + 1 , j ] ,枚举 i,k,k+1,j i , k , k + 1 , j 的颜色,因为 k k k+1 相邻,所以二者的颜色必然不同或没有涂色,在此条件下,转移方程为
    dp[i][j][x][y]+=dp[i][k][x][q]dp[k+1][j][p][y] d p [ i ] [ j ] [ x ] [ y ] + = d p [ i ] [ k ] [ x ] [ q ] ∗ d p [ k + 1 ] [ j ] [ p ] [ y ]
    x,y,p,q[0,2](pq|p=0) 其 中 : x , y , p , q ∈ [ 0 , 2 ] 且 ( p ≠ q | p = 0 )
代码:
#include<bits/stdc++.h>
using namespace std;

#define bll long long

const int maxn = 770;
const int mod = 1e9+7;
int n,match[maxn];
long long dp[maxn][maxn][3][3];
char s[maxn];

void getmatch()
{
    stack <int> st;
    for (int i=1;i<=n;i++)
        if (s[i] == '(') st.push(i);
        else
        {
            match[i] = st.top();
            match[st.top()] = i;
            st.pop();
        }
    return;
}

void solve(int l,int r)
{
    if (l+1 == r)
    {
        for (int i=1;i<3;i++)
            dp[l][r][0][i] = dp[l][r][i][0] = 1;
        return;
    }
    if (match[l] == r)
    {
        solve(l+1,r-1);
        for (int i=0;i<3;i++)
            for (int j=0;j<3;j++)
                for (int color=1;color<3;color++)
                {
                    if (i!=color)
                        dp[l][r][color][0] = (dp[l][r][color][0] + dp[l+1][r-1][i][j]) % mod;
                    if (j!=color)
                        dp[l][r][0][color] = (dp[l][r][0][color] + dp[l+1][r-1][i][j]) % mod;
                }
    }
    else
    {
        int k = match[l];
        solve(l,k);
        solve(k+1,r);
        for (int i=0;i<3;i++)
            for (int j=0;j<3;j++)
                for (int x=0;x<3;x++)
                    for (int y=0;y<3;y++)
        if (j==0 || x!=j)
        {
            bll tmp = dp[l][k][i][j]*dp[k+1][r][x][y] % mod;
            dp[l][r][i][y] = (dp[l][r][i][y]+tmp) % mod;
        }
    }
    return;
}

int main()
{
    scanf("%s",s+1);
    n = strlen(s+1);
    getmatch();
    solve(1,n);
    long long ans = 0;
    for (int i=0;i<3;i++)
        for (int j=0;j<3;j++)
            ans = (ans + dp[1][n][i][j]) % mod;
    printf("%lld\n",ans);
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值