Halloween Costumes(区间DP)

Description

Gappu has a very busy weekend ahead of him. Because, next weekend is Halloween, and he is planning to attend as many parties as he can. Since it’s Halloween, these parties are all costume parties, Gappu always selects his costumes in such a way that it blends with his friends, that is, when he is attending the party, arranged by his comic-book-fan friends, he will go with the costume of Superman, but when the party is arranged contest-buddies, he would go with the costume of ‘Chinese Postman’.

Since he is going to attend a number of parties on the Halloween night, and wear costumes accordingly, he will be changing his costumes a number of times. So, to make things a little easier, he may put on costumes one over another (that is he may wear the uniform for the postman, over the superman costume). Before each party he can take off some of the costumes, or wear a new one. That is, if he is wearing the Postman uniform over the Superman costume, and wants to go to a party in Superman costume, he can take off the Postman uniform, or he can wear a new Superman uniform. But, keep in mind that, Gappu doesn’t like to wear dresses without cleaning them first, so, after taking off the Postman uniform, he cannot use that again in the Halloween night, if he needs the Postman costume again, he will have to use a new one. He can take off any number of costumes, and if he takes off k of the costumes, that will be the last k ones (e.g. if he wears costume A before costume B, to take off A, first he has to remove B).

Given the parties and the costumes, find the minimum number of costumes Gappu will need in the Halloween night.

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer N (1 ≤ N ≤ 100) denoting the number of parties. Next line contains N integers, where the ith integer ci (1 ≤ ci ≤ 100) denotes the costume he will be wearing in party i. He will attend party 1 first, then party 2, and so on.

Output

For each case, print the case number and the minimum number of required costumes.

Sample Input

2
4
1 2 1 2
7
1 2 1 1 3 2 1

Sample Output

Case 1: 3
Case 2: 4


题意:

主人公要参加宴会,参加宴会的次序是固定的,每场宴会需要穿对应的服装,用数字 (1100) ( 1 − 100 ) 表示。可以在衣服外面套上衣服,但是衣服脱下后,不能再次使用,问至少需要准备多少件衣服?

分析:

题意描述不太容易理解,以样例2为例

  • 穿上衣服1,参加第一场宴会; 衣着由里到外为 1
  • 在衣服1上套上衣服2,参加第二场宴会; 衣着由里到外为 1,2
  • 脱下衣服2,参加第三场和第四场宴会; 衣着由里到外为 1
  • 穿上衣服3,参加第五场宴会; 衣着由里到外为 1,3
  • 在衣服3上套上衣服2,参加第六场宴会; 衣着由里到外为 1,3,2
  • 脱下衣服2,衣服3,参加第七场宴会。衣着由里到外为 1

所以,最多需要准备4件衣服

定义状态 dp[i][j] d p [ i ] [ j ] : 第 i i 场到第j场需要的服装数量
对于当前状态,有两种决策:

  1. 在原有的基础上,穿上一件衣服,即
    dp[i][j]=min(dp[i][j],dp[i][j1]+1) d p [ i ] [ j ] = m i n ( d p [ i ] [ j ] , d p [ i ] [ j − 1 ] + 1 )
  2. 脱去一部分衣服,留下第 k k 次宴会穿的衣服,去参加第j次宴会,此时必须保证 c[j]=c[k] c [ j ] = c [ k ] ,即
    dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j1]) d p [ i ] [ j ] = m i n ( d p [ i ] [ j ] , d p [ i ] [ k ] + d p [ k + 1 ] [ j − 1 ] )
代码:
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
#include<time.h>
#include<iostream>
#include<vector>
#include<stack>
#include<queue>
#include<set>
#include<map>

using namespace std;

#define bll long long

const int maxn = 110;
int T,n,c[maxn];
int dp[maxn][maxn];

int main()
{
    scanf("%d",&T);
    for (int Case = 1; Case <= T; Case++)
    {
        scanf("%d",&n);
        for (int i=1;i<=n;i++) scanf("%d",&c[i]);

        memset(dp,0,sizeof(dp));
        for (int i=1;i<=n;i++)
            for (int j=i;j<=n;j++) dp[i][j] = j-i+1;

        for (int i=n;i>0;i--)
           for (int j=i+1;j<=n;j++)
           {
               dp[i][j] = min(dp[i][j],dp[i][j-1]+1);
               for (int k=i;k<j;k++)
                   if (c[k] == c[j])
                       dp[i][j] = min(dp[i][j],dp[i][k]+dp[k+1][j-1]);
           } 
        printf("Case %d: %d\n",Case,dp[1][n]);
    }
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值