Turing Tree

Turing Tree:http://acm.hdu.edu.cn/showproblem.php?pid=3333

Turing Tree

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8365    Accepted Submission(s): 3074


 

Problem Description

After inventing Turing Tree, 3xian always felt boring when solving problems about intervals, because Turing Tree could easily have the solution. As well, wily 3xian made lots of new problems about intervals. So, today, this sick thing happens again...

Now given a sequence of N numbers A1, A2, ..., AN and a number of Queries(i, j) (1≤i≤j≤N). For each Query(i, j), you are to caculate the sum of distinct values in the subsequence Ai, Ai+1, ..., Aj.

Input

The first line is an integer T (1 ≤ T ≤ 10), indecating the number of testcases below.
For each case, the input format will be like this:
* Line 1: N (1 ≤ N ≤ 30,000).
* Line 2: N integers A1, A2, ..., AN (0 ≤ Ai ≤ 1,000,000,000).
* Line 3: Q (1 ≤ Q ≤ 100,000), the number of Queries.
* Next Q lines: each line contains 2 integers i, j representing a Query (1 ≤ i ≤ j ≤ N).

Output

For each Query, print the sum of distinct values of the specified subsequence in one line.

Sample Input

2

3

1 1 4

2

1 2

2 3

5

1 1 2 1 3

3

1 5

2 4

3 5

Sample Output

1

5

6

3

6

#include<bits/stdc++.h>
using namespace std;
const long long maxn=1e5+100;
long long a[maxn];
long long b[maxn];
struct node
{
    long long l,r,sum,id;
} sz[maxn];
long long tot,sum;
unordered_map<long long,int>ma;
bool cmp(node x,node y)
{
    return b[x.l]==b[y.l]?x.r<y.r:x.l<y.l;
}
bool CMP(node x,node y)
{
    return x.id<y.id;
}
void revise(long long v,long long pos)
{
    if(pos==1)
    {
        ma[a[v]]++;
        if(ma[a[v]]==1)
            sum+=a[v];
    }
    else
    {
            ma[a[v]]--;
            if(ma[a[v]]==0)
                sum-=a[v];   
    }
}
int main()
{
    long long t;
    scanf("%lld",&t);
    while(t--)
    {
        memset(a,0,sizeof a);
        memset(b,0,sizeof b);
        memset(sz,0,sizeof sz);
        ma.clear();
        sum=0;
        long long n;
        scanf("%lld",&n);
        long long block=sqrt(n);
        for(long long i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
            b[i]=i/block+1;
        }
        long long m;
        scanf("%lld",&m);
        for(long long i=1; i<=m; i++)
        {
            long long x,y;
            scanf("%lld %lld",&x,&y);
            sz[i].l=x,sz[i].r=y;
            sz[i].id=i;
        }
        sort(sz+1,1+sz+m,cmp);
        long long r=0,l=1;
        for(long long i=1; i<=m; i++)
        {
            while(l<sz[i].l)    revise(l,-1),l++;
            while(l>sz[i].l)    revise(l-1,1),l--;
            while(r>sz[i].r)    revise(r,-1),r--;
            while(r<sz[i].r)    revise(r+1,1),r++;
            sz[i].sum=sum;
        }
        sort(sz+1,sz+m+1,CMP);
        for(long long i=1; i<=m; i++)
        {
            printf("%lld\n",sz[i].sum);
        }
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值