HDU 5038 Grade

HDU 5038 Grade

Problem Description
Ted is a employee of Always Cook Mushroom (ACM). His boss Matt gives him a pack of mushrooms and ask him to grade each mushroom according to its weight. Suppose the weight of a mushroom is w, then it’s grade s is

s = 10000 - (100 - w)^2

What’s more, Ted also has to report the mode of the grade of these mushrooms. The mode is the value that appears most often. Mode may not be unique. If not all the value are the same but the frequencies of them are the same, there is no mode.

Input
The first line of the input contains an integer T, denoting the number of testcases. Then T test cases follow.

The first line of each test cases contains one integers N (1<=N<=10^6),denoting the number of the mushroom.

The second line contains N integers, denoting the weight of each mushroom. The weight is greater than 0, and less than 200.

Output
For each test case, output 2 lines.

The first line contains “Case #x:”, where x is the case number (starting from 1)

The second line contains the mode of the grade of the given mushrooms. If there exists multiple modes, output them in ascending order. If there exists no mode, output “Bad Mushroom”.

Sample Input
3
6
100 100 100 99 98 101
6
100 100 100 99 99 101
6
100 100 98 99 99 97

Sample Output
Case #1:
10000
Case #2:
Bad Mushroom
Case #3:
9999 10000

简单来说就是求转换后的grade中的众数(不查词还真不知道众数的英文是mode,涨姿势了),根据题目中说明的和定义,注意两点:

①如果不是所有数都相同但是各个数的出现次数相同,那么没有众数;
②如果所有数都相同,那么众数就是这个数;

理解题意后首先想到用map,输入时可以同时找出最大的出现次数,然后把这些数挑出来,判断一下是否有众数然后输出就行。

参考代码:

#include <bits/stdc++.h>
using namespace std;
int t, n, tmp, cnt = 1, maxt;
map<int, int> m;
vector<int> v;
int main(int argc, char const *argv[]) {
    cin >> t;
    while (t--) {
        maxt = -1;
        m.clear();
        v.clear();
        cin >> n;
        for(int i = 0; i < n; i++){
            scanf("%d", &tmp);
            tmp = 10000 - (100 - tmp)*(100 - tmp);
            m[tmp]++;
            if(m[tmp] > maxt) maxt = m[tmp];
        }
        map<int, int> :: iterator it = m.begin();
        for(it; it != m.end(); it++){
            if((*it).second == maxt) v.push_back((*it).first);
        }
        printf("Case #%d:\n", cnt++);
        if(maxt*v.size() == n && v.size() != 1){ //出现次数相同的话就会导致maxt*v.size() == n
            puts("Bad Mushroom");
        }
        else{
            for(int i = 0; i < v.size(); i++){
                if(i == 0) printf("%d", v[i]);
                else printf(" %d", v[i]);
            }
            puts("");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值