hdu 3829 Cat VS Dog 【二分图求最大独立集】

67 篇文章 0 订阅
34 篇文章 0 订阅

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=3829

题目来源: http://acm.hust.edu.cn:8080/judge/contest/view.action?cid=17572#problem/E (CSUST图论训练赛)

二分匹配,求最大独立集。

Cat VS Dog

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)
Total Submission(s): 1870    Accepted Submission(s): 633


Problem Description
The zoo have N cats and M dogs, today there are P children visiting the zoo, each child has a like-animal and a dislike-animal, if the child's like-animal is a cat, then his/hers dislike-animal must be a dog, and vice versa.
Now the zoo administrator is removing some animals, if one child's like-animal is not removed and his/hers dislike-animal is removed, he/she will be happy. So the administrator wants to know which animals he should remove to make maximum number of happy children.
 

Input
The input file contains multiple test cases, for each case, the first line contains three integers N <= 100, M <= 100 and P <= 500.
Next P lines, each line contains a child's like-animal and dislike-animal, C for cat and D for dog. (See sample for details)
 

Output
For each case, output a single integer: the maximum number of happy children.
 

Sample Input
  
  
1 1 2 C1 D1 D1 C1 1 2 4 C1 D1 C1 D1 C1 D2 D2 C1
 

Sample Output
  
  
1 3
Hint
Case 2: Remove D1 and D2, that makes child 1, 2, 3 happy.
 

Source
 

Recommend
xubiao

题意:动物园有N只猫,M条狗。有P个小朋友去动物园参观,每个小朋友都喜欢一只猫,讨厌一条狗,或者喜欢一条狗,讨厌一只猫。

           现在管理员要移除一些动物,如果一个小朋友喜欢的动物没有被移走,讨厌的动物却被移走了,那么他就会高兴,求出最多会有多少个小朋友高兴。

思路:来自kuangbin神(PS:自己怎么也不会想到如此建图啊Orz敲打,开始没有用strcmp函数,然后建图也弄复杂了,一路TLE到死啊哭

           以小孩儿为点,如果两个小孩矛盾(你喜欢的我不喜欢,或者我喜欢的你不喜欢,那么你我之间就产生了矛盾,建边),就在他们之间建立一条边。

PS:小张haha一个效率很高的代码31ms ,目测没有理解http://www.cnblogs.com/zhsl/archive/2012/11/27/2790961.html

算法:二分匹配求最大独立集

           二分图最大独立集=顶点数-二分图最大匹配。

代码一:

//kb神的邻接表算法,效率较高C++,78ms
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<vector>
using namespace std;
const int maxn=510;
int linker[maxn];
bool used[maxn];
vector<int>map[maxn];
int uN;
bool dfs(int u)
{
    for(int i=0;i<map[u].size();i++)
    {
        if(!used[map[u][i]])
        {
            used[map[u][i]]=true;
            if(linker[map[u][i]]==-1 || dfs(linker[map[u][i]]))
            {
                linker[map[u][i]]=u;
                return true;
            }
        }
    }
    return false;
}
int hungary()
{
    int u;
    int res=0;
    memset(linker,-1,sizeof(linker));
    for(u=0;u<uN;u++)
    {
        memset(used,false,sizeof(used));
        if(dfs(u)) res++;
    }
    return res;
}
char like[maxn][5];
char dislike[maxn][5];
int main()
{
    int n,m,p;
    while(scanf("%d%d%d",&n,&m,&p)!=EOF)
    {
        uN=p;
        for(int i=0;i<maxn;i++) map[i].clear();
        for(int i=0;i<p;i++) scanf("%s%s",&like[i],&dislike[i]);
        for(int i=0;i<p;i++)
        {
            for(int j=i+1;j<p;j++)
                if(strcmp(like[i],dislike[j])==0 || strcmp(like[j],dislike[i])==0)
                {
                    map[i].push_back(j);
                    map[j].push_back(i);
                }
        }
        printf("%d\n",p-hungary()/2);//以小孩儿为点集,小孩用了两次,所以除以二
    }
    return 0;
}

代码二:
//普通匈牙利算法218ms
#include<stdio.h>
#include<cstring>
const int maxn=510;
bool used[maxn];
int linker[maxn];
int g[maxn][maxn];
int uN,vN;
int n,m,p;
char like[maxn][5];
char dislike[maxn][5];
bool dfs(int u)
{
    int v;
    for(v=1;v<=vN;v++)
    {
        if(!used[v] && g[u][v])
        {
            used[v]=true;
            if(linker[v]==-1 || dfs(linker[v]))
            {
                linker[v]=u;
                return true;
            }
        }
    }
    return false;
}
int hungary()
{
    int sum=0;
    memset(linker,-1,sizeof(linker));
    for(int u=1;u<=uN;u++)
    {
        memset(used,false,sizeof(used));
        if(dfs(u)) sum++;
    }
    return sum;
}
int main()
{
    while(scanf("%d%d%d",&n,&m,&p)!=EOF)
    {
        uN=vN=p;
        memset(g,0,sizeof(g));
        for(int i=1;i<=p;i++)
        {
            scanf("%s%s",&like[i],&dislike[i]);
        }
        for(int i=1;i<=p;i++)
        {
            for(int j=i+1;j<=p;j++)
            {
                if(strcmp(like[i],dislike[j])==0 || strcmp(like[j],dislike[i])==0)
                {
                    g[i][j]=1;
                    g[j][i]=1;
                }
            }
        }
        printf("%d\n",p-hungary()/2);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值