HDU 5980 icpc 大连

Find Small A

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 766    Accepted Submission(s): 250


Problem Description
As is known to all,the ASCII of character 'a' is 97. Now,find out how many character 'a' in a group of given numbers. Please note that the numbers here are given by 32 bits’ integers in the computer.That means,1digit represents 4 characters(one character is represented by 8 bits’ binary digits).
 

Input
The input contains a set of test data.The first number is one positive integer N (1≤N≤100),and then N positive integersai (1≤  a_i ≤2^32 - 1) follow
 

Output
Output one line,including an integer representing the number of 'a' in the group of given numbers.
 

Sample Input
  
  
3 97 24929 100
 

Sample Output
  
  
3

题目大意:


每个数是由32位二进制组成。将这 32 位拆成 4 个二进制数字,如果有 97 那么ans ++


思路:


直接模拟拆就可以了。


AC代码:


#include<bits/stdc++.h>
using namespace std;
int main()
{
    int T;
    int n;
    int ss[35];
    int a;
    while(~scanf("%d",&n))
    {
        int cnt;
        int tt;
        int ans=0;
        for(int i=0;i<n;i++)
        {
            cnt=0;
            scanf("%d",&a);
            while(a>0)
            {
                ss[cnt++]=a&1;
                a/=2;
            }
            tt=0;
            for(int j=0;j<8&&j<cnt;j++)
            {
                if(ss[j])
                    tt+=pow(2,j);
            }
            if(tt==97)
            {
                ans++;
            }
            tt=0;
            for(int j=8;j<16&&j<cnt;j++)
            {
                if(ss[j])
                    tt+=pow(2,j-8);
            }
            if(tt==97)
            {
                ans++;
            }
            tt=0;
            for(int j=16;j<24&&j<cnt;j++)
            {
                if(ss[j])
                    tt+=pow(2,j-16);
            }
            if(tt==97)
            {
                ans++;
            }
            tt=0;
            for(int j=24;j<32&&j<cnt;j++)
            {
                if(ss[j])
                    tt+=pow(2,j-24);
            }
            if(tt==97)
            {
                ans++;
            }
            tt=0;
        }
        cout<<ans<<endl;
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值