Cat VS Dog HDU - 3829 最大独立集

The zoo have N cats and M dogs, today there are P children visiting the zoo, each child has a like-animal and a dislike-animal, if the child's like-animal is a cat, then his/hers dislike-animal must be a dog, and vice versa.
Now the zoo administrator is removing some animals, if one child's like-animal is not removed and his/hers dislike-animal is removed, he/she will be happy. So the administrator wants to know which animals he should remove to make maximum number of happy children.

Input
The input file contains multiple test cases, for each case, the first line contains three integers N <= 100, M <= 100 and P <= 500.
Next P lines, each line contains a child's like-animal and dislike-animal, C for cat and D for dog. (See sample for details)
Output
For each case, output a single integer: the maximum number of happy children.
Sample Input
1 1 2
C1 D1
D1 C1

1 2 4
C1 D1
C1 D1
C1 D2
D2 C1
Sample Output
1
3


        
  
Hint
Case 2: Remove D1 and D2, that makes child 1, 2, 3 happy. 


最大独立集:找到这么一个点集:

1.集合内任何找出的两点都没有关系

2.使这个集合最大

这就是最大独立集,算法:总点数-最大匹配

那么对于这道题,是在人之间找到这么一个独立集,这样的话,如果一个人喜欢,另一个人不喜欢或者一个人不喜欢,另一个人喜欢,他们就有关系,就建立这么一个图,求一个最大独立集就可以。别忘了/2

#include<bits/stdc++.h>
using namespace std;
const int M=510;
bool gra[M][M],used[M];
int mached[M],a,b,p;
struct aa
{
    char like[20];
    char dislike[20];
} s[M];
bool findx(int u)
{
    for(int i=1;i<=p;i++)
    {
        if(gra[u][i]&&used[i]==0)
        {
            used[i]=1;
            if(mached[i]==-1||findx(mached[i]))
            {
                mached[i]=u;
                return 1;
            }
        }
    }
    return 0;
}
int hungary()
{
    int ans=0;
    memset(mached,-1,sizeof(mached));
    for(int i=1;i<=p;i++)
    {
        memset(used,0,sizeof(used));
        if(findx(i))ans++;
    }
    return ans;
}
int main()
{
    while(scanf("%d%d%d",&a,&b,&p)!=EOF)
    {
        memset(gra,0,sizeof(gra));
        for(int i=1; i<=p; i++)
        {
            scanf("%s%s",s[i].like,s[i].dislike);
        }
        for(int i=1; i<=p; i++)
            for(int j=1; j<=p; j++)
            {
                if(strcmp(s[i].like,s[j].dislike)==0||strcmp(s[i].dislike,s[j].like)==0)
                {
                    gra[i][j]=1;
                }
            }
        int ans=hungary();
        printf("%d\n",p-ans/2);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值