HDU-3829 Cat VS Dog(最大独立集)


L - Cat VS Dog
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

The zoo have N cats and M dogs, today there are P children visiting the zoo, each child has a like-animal and a dislike-animal, if the child's like-animal is a cat, then his/hers dislike-animal must be a dog, and vice versa.  
Now the zoo administrator is removing some animals, if one child's like-animal is not removed and his/hers dislike-animal is removed, he/she will be happy. So the administrator wants to know which animals he should remove to make maximum number of happy children.  

Input

The input file contains multiple test cases, for each case, the first line contains three integers N <= 100, M <= 100 and P <= 500.  
Next P lines, each line contains a child's like-animal and dislike-animal, C for cat and D for dog. (See sample for details)  

Output

For each case, output a single integer: the maximum number of happy children.

Sample Input

1 1 2
C1 D1
D1 C1

1 2 4
C1 D1
C1 D1
C1 D2
D2 C1

Sample Output

1
3


        
  

这是一道求最大独立集的题,首先先要建立二部图,在建立时,如果child_i喜欢的是
child_j讨厌的,或者child_i讨厌的是child_j喜欢的,那么在child_i和child_j之间建
边,此时他们是敌人的关系,既相互排斥的。要求的结果是在去掉一些dog或者cat
后使能够让孩子高兴的孩子数达到最大,既他们之间不存在相互排斥的关系,所要求的
结果转化为求最小路径覆盖;
最大独立集=最小路径覆盖=顶点个数(孩子数)-匹配数;
因为每一对敌人关系都被重复使用两次,所以匹配数=最大匹配量/2;

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<limits.h>
#include<queue>
#include<math.h>
#include<algorithm>
using namespace std;
#define maxn 505
int n,m,k;
int map[maxn][maxn];
char s1[maxn][2];
char s2[maxn][2];
int ans[maxn];
int v[maxn];
struct node
{
	char like[5];
	char dislike[5];
}str[maxn];
int dfs(int x)
{
	for(int i=1;i<=k;i++)
	{
		if(map[x][i] && !ans[i])
		{
			ans[i]=1;
			if(v[i]==0 || dfs(v[i]))
			{ 
			      v[i]=x;
			      return 1;
		    }
	    }
	}
	return 0;
}
int  main()
{
	int i,j;
	while(scanf("%d%d%d",&n,&m,&k)!=EOF)
	{
		memset(v,0,sizeof(v));
		memset(map,0,sizeof(map));
		for(i=1;i<=k;i++)
			scanf("%s %s",str[i].like,str[i].dislike);
		for(i=1;i<=k;i++)
		    for(j=1;j<=k;j++)
			{
				if(strcmp(str[i].like,str[j].dislike)==0 || strcmp(str[i].dislike,str[j].like)==0)
				   map[i][j]=1;
			 } 
		int sum=0;
		for(i=1;i<=k;i++)
		{
			memset(ans,0,sizeof(ans));
			int t=dfs(i);
			if(t)
			    sum++;
		}
		printf("%d\n",k-sum/2);
	}
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值