【POJ 2420】 A Star not a Tree?(模拟退火)

【POJ 2420】 A Star not a Tree?(模拟退火)


A Star not a Tree?
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4788 Accepted: 2326

Description

Luke wants to upgrade his home computer network from 10mbs to 100mbs. His existing network uses 10base2 (coaxial) cables that allow you to connect any number of computers together in a linear arrangement. Luke is particulary proud that he solved a nasty NP-complete problem in order to minimize the total cable length. 
Unfortunately, Luke cannot use his existing cabling. The 100mbs system uses 100baseT (twisted pair) cables. Each 100baseT cable connects only two devices: either two network cards or a network card and a hub. (A hub is an electronic device that interconnects several cables.) Luke has a choice: He can buy 2N-2 network cards and connect his N computers together by inserting one or more cards into each computer and connecting them all together. Or he can buy N network cards and a hub and connect each of his N computers to the hub. The first approach would require that Luke configure his operating system to forward network traffic. However, with the installation of Winux 2007.2, Luke discovered that network forwarding no longer worked. He couldn't figure out how to re-enable forwarding, and he had never heard of Prim or Kruskal, so he settled on the second approach: N network cards and a hub. 

Luke lives in a loft and so is prepared to run the cables and place the hub anywhere. But he won't move his computers. He wants to minimize the total length of cable he must buy.

Input

The first line of input contains a positive integer N <= 100, the number of computers. N lines follow; each gives the (x,y) coordinates (in mm.) of a computer within the room. All coordinates are integers between 0 and 10,000.

Output

Output consists of one number, the total length of the cable segments, rounded to the nearest mm.

Sample Input

4
0 0
0 10000
10000 10000
10000 0

Sample Output

28284

Source


以前经常遇到模拟退火 然而已知没遇到实题 没能用于实践 也没能理解 毕竟论文什么的讲的都很抽象

今天做题遇到这个 根本没想到会用这个方法

模拟退火 并不是字面意思 而是一种化学变化 在物体内部的一种反应 不断降温 每当到一个温度会先趋向于稳定状态 再继续降温(个人理解)

用到编程上  就是个迭代 不断缩小答案的偏移量 也就是温度

每到一个偏移量 找出这个偏移量下的最优解 也就是在这个偏移量下往所有位置搜索 贪心的找最优(稳定状态) 毕竟随机算法…… 

找到就更新 直到找不到 把温度(偏移量)降低 接着找 已知找到一个边界(自己估计个)


代码如下:


#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>

using namespace std;
const int INF = 0x3f3f3f3f;

struct Point
{
    double x,y;
    Point(){}
    Point(double _x,double _y):x(_x),y(_y){}
    double operator ^ (const struct Point a)const
    {
        return sqrt((x-a.x)*(x-a.x)+(y-a.y)*(y-a.y));
    }
};

Point pt[111];
int n;

double aldis(double x,double y)
{
    double ans = 0;
    Point p = Point(x,y);
    for(int i = 0; i < n; ++i) ans += p^pt[i];
    return ans;
}

int main()
{
    //st----温度 mn-----答案
    double st,mn,tmp,x,y;
    bool f;
    while(~scanf("%d",&n))
    {
        for(int i = 0; i < n; ++i) scanf("%lf %lf",&pt[i].x,&pt[i].y);

        st = 10000;
        x = y = 0;
        mn = aldis(x,y);
        //st = 10000是初始温度 f表示该偏移量下是否仍可让答案更优 st > 0.2表示边界
        for(st = 10000,f = 1; st > 0.2; st = st/2, f = 1)
        {
            //f == 1  该温度下未到最优 继续退(迭代)
            while(f)
            {
                f = 0;
                for(int i = -1; i <= 1; ++i)
                {
                    for(int j = -1; j <= 1; ++j)
                    {
                        tmp = aldis(x+st*i,y+st*j);
                        //评价函数
                        if(tmp < mn)
                        {
                            x = x+st*i;
                            y = y+st*j;
                            f = 1;
                            mn = tmp;
                        }
                    }
                }
            }
        }
        printf("%.0f\n",mn);
    }

    return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,这个问题属于技术问题。以下是一个简单的Python模拟登录POJ提交代码并抓取评测结果的代码示例: ```python import requests # 登录POJ,获取cookie def login(username, password): s = requests.Session() login_url = "http://poj.org/login" login_data = { "user_id1": username, "password1": password, "B1": "login", "url": "/" } s.post(login_url, data=login_data) return s # 提交代码 def submit_code(s, problem_id, language, source_code): submit_url = "http://poj.org/submit" submit_data = { "problem_id": problem_id, "language": language, "source": source_code } s.post(submit_url, data=submit_data) # 获取评测结果 def get_result(s, run_id): status_url = "http://poj.org/status" params = { "user_id": "", "result": "", "language": "", "top": run_id } r = s.get(status_url, params=params) table_start = r.text.find("<table cellpadding=0 cellspacing=0 border=0 width=100%>") table_end = r.text.find("</table>", table_start) table_html = r.text[table_start:table_end + 8] return table_html # 使用示例 username = "your_username" password = "your_password" problem_id = "1000" language = "G++" source_code = """ #include <iostream> using namespace std; int main() { int a, b; cin >> a >> b; cout << a + b << endl; return 0; } """ s = login(username, password) submit_code(s, problem_id, language, source_code) table_html = get_result(s, "12345678") # 替换成实际提交的run id print(table_html) ``` 其中,`login`函数模拟登录POJ并返回一个`Session`对象,`submit_code`函数提交代码,`get_result`函数获取评测结果。你可以根据实际需要修改代码中的`username`、`password`、`problem_id`、`language`和`source_code`等参数,并替换`get_result`函数中的`run_id`。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值