poj 2420 A Star not a Tree?(模拟退火)

A Star not a Tree?
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3074 Accepted: 1557

Description

Luke wants to upgrade his home computer network from 10mbs to 100mbs. His existing network uses 10base2 (coaxial) cables that allow you to connect any number of computers together in a linear arrangement. Luke is particulary proud that he solved a nasty NP-complete problem in order to minimize the total cable length.
Unfortunately, Luke cannot use his existing cabling. The 100mbs system uses 100baseT (twisted pair) cables. Each 100baseT cable connects only two devices: either two network cards or a network card and a hub. (A hub is an electronic device that interconnects several cables.) Luke has a choice: He can buy 2N-2 network cards and connect his N computers together by inserting one or more cards into each computer and connecting them all together. Or he can buy N network cards and a hub and connect each of his N computers to the hub. The first approach would require that Luke configure his operating system to forward network traffic. However, with the installation of Winux 2007.2, Luke discovered that network forwarding no longer worked. He couldn't figure out how to re-enable forwarding, and he had never heard of Prim or Kruskal, so he settled on the second approach: N network cards and a hub.

Luke lives in a loft and so is prepared to run the cables and place the hub anywhere. But he won't move his computers. He wants to minimize the total length of cable he must buy.

Input

The first line of input contains a positive integer N <= 100, the number of computers. N lines follow; each gives the (x,y) coordinates (in mm.) of a computer within the room. All coordinates are integers between 0 and 10,000.

Output

Output consists of one number, the total length of the cable segments, rounded to the nearest mm.

Sample Input

4
0 0
0 10000
10000 10000
10000 0

Sample Output

28284

Source



题意:求任意多边形费马点
题解:随机变步长模拟贪心....

#include<stdio.h>
#include<math.h>
struct point{
    double x,y;
    point(){}
    point(double _x,double _y):x(_x),y(_y){};
}p[108],now,temp;
int n,way[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
double dis(point a,point b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double alldis(point tag)
{
    double sum=0;
    for(int i=0;i<n;i++) sum+=dis(tag,p[i]);
    return sum;
}
int main()
{
    while(scanf("%d",&n)>0)
    {
        for(int i=0;i<n;i++) scanf("%lf%lf",&p[i].x,&p[i].y);
        now=point(0,0);
        double step=100,best=alldis(now);
        while(step>0.1)
        {
            bool flag=true;
            while(flag)
            {
                flag=false;
                for(int i=0;i<4;i++)
                {
                    temp=point(way[i][0]*step+now.x,way[i][1]*step+now.y);
                    double len=alldis(temp);
                    if(len<best)
                    {
                        best=len;
                        now=temp;
                        flag=true;
                    }
                }
            }
            step=step/2.0;
        }
        printf("%d\n",(int)(best+0.5));
    }

    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值