1005 Spell It Right (20分)

这篇博客展示了如何使用Java和C++编程语言,计算一个不超过10^100的非负整数的所有数字之和,并将结果以英文单词形式输出。博主分享了一段Java和C++的代码,实现了从输入的整数到其数字和的英文表示的转换。尽管长时间未接触Java,博主仍能迅速编写出基本的解决方案。
摘要由CSDN通过智能技术生成

1005 Spell It Right (20分)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

~

半年没写过Java了,原以为不会写了,但是竟然可以一遍就写出来(当然只是最基本的输入输出)

在这里插入图片描述

几乎一样的代码,时间确实差的离谱

代码_Java

import java.util.Scanner;
public class a005
{
    public static void main(String []args)
    {
        String str=new String();
        Scanner sc=new Scanner(System.in);
        str=sc.next();
        int cnt=0;
        for(int i=0;i<str.length();++i)
            cnt+=(int)(str.charAt(i)-'0');
        String [] nums={"zero","one","two","three","four","five","six","seven","eight","nine"};
        String tmp=Integer.toString(cnt);
        for(int i=0;i<tmp.length();++i)
        {
            if(i!=0)
                System.out.print(" ");
            System.out.print(nums[tmp.charAt(i)-'0']);
        }

    }
}

代码_cpp

#include <iostream>
#include <string>
using namespace std;
int main()
{
    string str;
    cin >> str;
    int cnt = 0;
    for (int i = 0; i < str.size(); ++i)
        cnt += (int)(str[i] - '0');
    string nums[10] = {"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};
    string tmp = to_string(cnt);
    for (int i = 0; i < tmp.length(); ++i)
    {
        if (i != 0)
            cout << " ";
        cout << nums[tmp[i] - '0'];
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值