1005 Spell It Right (20分)
Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.
Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (≤10100).
Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.
Sample Input:
12345
Sample Output:
one five
~
半年没写过Java了,原以为不会写了,但是竟然可以一遍就写出来(当然只是最基本的输入输出)
几乎一样的代码,时间确实差的离谱
代码_Java
import java.util.Scanner;
public class a005
{
public static void main(String []args)
{
String str=new String();
Scanner sc=new Scanner(System.in);
str=sc.next();
int cnt=0;
for(int i=0;i<str.length();++i)
cnt+=(int)(str.charAt(i)-'0');
String [] nums={"zero","one","two","three","four","five","six","seven","eight","nine"};
String tmp=Integer.toString(cnt);
for(int i=0;i<tmp.length();++i)
{
if(i!=0)
System.out.print(" ");
System.out.print(nums[tmp.charAt(i)-'0']);
}
}
}
代码_cpp
#include <iostream>
#include <string>
using namespace std;
int main()
{
string str;
cin >> str;
int cnt = 0;
for (int i = 0; i < str.size(); ++i)
cnt += (int)(str[i] - '0');
string nums[10] = {"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};
string tmp = to_string(cnt);
for (int i = 0; i < tmp.length(); ++i)
{
if (i != 0)
cout << " ";
cout << nums[tmp[i] - '0'];
}
}