浙大数据结构慕课课后题(02-线性结构3 Reversing Linked List)

题目要求:

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

输入格式:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next 

where Address is the position of the node, Data is an integer, and Next is the position of the next node. 

输出格式: 

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input. 

 样例输入:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

样例输出: 

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1 

题目翻译:

题解: 

        思路如注释所示,可通过所有测试点。

#include<bits/stdc++.h>

using namespace std;

struct Node{
	int address;
	int data;
	int next;
};

int main(){
	int start,N,K;
	cin>>start>>N>>K;
	
	const int MAXN = 100000;
	Node nodes[MAXN]; //存储所有节点
	int result[MAXN]; //存储逆序后的链表地址
	
	for(int i=0;i<N;i++){
		int address,data,next;
		cin>>address>>data>>next;
		nodes[address] = {address,data,next};
	} 
	
	//重新构造链表 
	int count = 0;
	int current = start;
	while(current != -1){
		result[count++] = current;
		current = nodes[current].next;		
	}
	
	//进行链表逆转
	//直接交换链表的地址值进行逆置 
	for(int i = 0;i+K <= count;i += K){
		for(int j = 0;j<K/2;j++){
			int tmp = result[i+j];
			result[i+j] = result[i+K-1-j];
			result[i+K-1-j] = tmp;   	
		} 
	}
	
	//输出结果
	for(int i=0;i<count;i++){
		int address = result[i];
		int data = nodes[address].data;
		int next = (i!=count-1) ? result[i+1]:-1;
		
		printf("%05d %d ",address,data);
		if(next == -1)
			printf("-1\n");
		else
			printf("%05d\n",next);
	}
	 
	return 0;
} 

关于此题注意要点:

        1. 对链表的存储,使用了结构数组的方法,这样可以直接存储并操作其地址,这样我们在进行逆转时直接交换两个节点的地址即可。

        2.使用result数组对链表中的元素进行一个有序的存储,这样可以在交换个别节点地址时保证链表本身的有序性。

闲谈:

        因为我本身不是专业参加竞赛选手,自己编码能力暂时有限,我本身想用陈姥姥上课方法实现此题。理解了她讲的大概思路,但是总是细节处理不当,也没有找到很清晰的题解,故而换了一种思路求解,可能实现过程更加简单一点,也能解出来题,但是对编码能力锻炼不强,点到即止吧。(上周发烧停更了一周,有些懈怠,痛定思痛继续打卡)

        咳咳项目突然催进度了,等我把数据库学完再回归:( 

  • 26
    点赞
  • 16
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
目描述 给定一个常数 $K$ 以及一个单链表 $L$,请编写程序将 $L$ 中每 $K$ 个结点反转。例如:给定 $L$ 为 1→2→3→4→5→6,$K$ 为 3,则输出应该为 3→2→1→6→5→4;如果 $K$ 为 4,则输出应该为 4→3→2→1→5→6,即最后不到 $K$ 个元素不反转。 输入格式 每个输入包含一个测试用例。每个测试用例第 1 行给出第 1 个结点的地址、结点总个数正整数 $N (\le 10^5)$、以及正整数 $K (\le N)$,即要求反转的子链结点的个数。结点的地址是 5 位非负整数,NULL 地址用 −1 表示。 接下来有 $N$ 行,每行格式为: Address Data Next 其中 Address 是结点地址;Data 是该结点保存的整数数据;Next 是下一结点的地址。目保证给出的链表不为空。 输出格式 对每个测试用例,顺序输出反转后的链表,其上每个结点占一行,格式与输入相同。 输入样例 00100 6 4 00000 4 99999 00100 1 12309 68237 6 -1 33218 3 00000 99999 5 68237 23333 2 33218 输出样例 00000 4 33218 33218 3 12309 12309 1 99999 99999 5 68237 68237 6 23333 23333 2 -1 目分析 本需要将链表中每 $K$ 个结点反转,可以采用迭代的方法,每次找到 $K$ 个结点,将这 $K$ 个结点反转,然后将这 $K$ 个结点的前驱结点指向反转后的第一个结点,将反转后的 $K$ 个结点的最后一个结点指向下一个要反转的结点,然后继续进行下一轮反转。 需要注意的是,如果链表长度不足 $K$,则不进行反转。 代码实现
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值