Matrix Swapping II
Time Limit : 9000/3000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 16 Accepted Submission(s) : 8
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness.
We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.
We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.
Input
There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix
Output
Output one line for each test case, indicating the maximum possible goodness.
Sample Input
3 4 1011 1001 0001 3 4 1010 1001 0001
Sample Output
4 2 Note: Huge Input, scanf() is recommended.
Source
2009 Multi-University Training Contest 2 - Host by TJU
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 1005;
int n, m,ans;
char mx[maxn][maxn];
int dp[maxn][maxn];
int s[maxn];
int val(int a, int b) {
int res = 0;
while (mx[a][b]==1) {
a--;
res++;
}
return res;
}
int mmax(int a, int b) {
if (a > b) return a;
return b;
}
int main()
{
std::ios::sync_with_stdio(false);
while (cin >> n >> m) {
memset(mx, 0, sizeof(mx));
memset(dp, 0, sizeof(dp));
memset(s, 0, sizeof(s));
ans = 0;
for (int i = 1; i <= n; i++)
for (int j = 1; j <= m; j++) {
cin >> mx[i][j];
}
for (int i = 1; i <= n; i++) {
int k = 0;
for (int j = 1; j <= m; j++) {
if (mx[i][j] == '1')
dp[i][j] = dp[i - 1][j]+1;
s[k++] = dp[i][j];
}
sort(s, s + k);
for (int u = 0; u < k; u++)
ans = mmax(ans, s[u] * (k - u));
}
cout << ans << endl;
}
return 0;
}