STL(四)map

map映射

map就是从键(key)到值(value)的映射。因为重载了[]运算符,map像是数组的“高级版”。例如可以用一个map< string,int >month_name来表示“月份名字到月份编号”的映射,然后用month_name[“July”]=7这样的方式来赋值。
set头文件中的set和map头文件中的map分别是集合与映射。二者都支持insert、find、count和remove操作,并且可以按照从小到大的顺序循环遍历其中的元素。map还提供了“[]”运算符,使得map可以像数组一样使用。事实上,map也称为“关联数组”

find()查找一个元素
insert()插入元素
count()返回指定元素出现的次数

Set.remove方法——移除Set集合中的指定对象
https://book.2cto.com/201309/31816.html

例题:UVa 156 Ananagrams

Most crossword puzzle fans are used to anagrams — groups of words with the same letters in different
orders — for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this
attribute, no matter how you rearrange their letters, you cannot form another word. Such words are
called ananagrams, an example is QUIZ.
Obviously such definitions depend on the domain within which we are working; you might think
that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible
domain would be the entire English language, but this could lead to some problems. One could restrict
the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the
same domain) but NOTE is not since it can produce TONE.
Write a program that will read in the dictionary of a restricted domain and determine the relative
ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be
“rearranged” at all. The dictionary will contain no more than 1000 words.
Input
Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any
number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken
across lines. Spaces may appear freely around words, and at least one space separates multiple words
on the same line. Note that words that contain the same letters but of differing case are considered to
be anagrams of each other, thus ‘tIeD’ and ‘EdiT’ are anagrams. The file will be terminated by a line
consisting of a single ‘#’.
Output
Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram
in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always
be at least one relative ananagram.
Sample Input
ladder came tape soon leader acme RIDE lone Dreis peat
ScAlE orb eye Rides dealer NotE derail LaCeS drIed
noel dire Disk mace Rob dries
#
Sample Output
Disk
NotE
derail
drIed
eye
ladder
soon

题目大意:
输入一些单词,找出所有满足如下条件的单词:该单词不能通过字母重排,得到输入文本中的另外一个单词。
在判断是否满足条件时,字母不分大小写,但在输入时应保留输入中的大小写,按字典序进行排列(所有大写字母在小写字母的前面)

我的代码:

#include<iostream>
#include<map>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;

map<string,int> cnt;///一个关联容器,它提供一对一(其中第一个可以称为关键字,
///每个关键字只能在map中出现一次,第二个可能称为该关键字的值)的数据处理能力
vector<string> words;

string repr(const string &s)
{
    string ans=s;///为后来保留大写
    for(int i=0;i<ans.length();i++)
        ans[i]=tolower(ans[i]);///把字母字符转换成小写,非字母字符不做出处理
    sort(ans.begin(),ans.end()); ///头文件 algorithm
    return ans;///返回已经排好的ans的数组
}

int main()
{
    int n=0;
    string s;
    while(cin>>s)
    {
        if(s[0]=='#') break;
        words.push_back(s); ///vector中push_back函数的意思是在vector的末尾插入一个元素。
        string r=repr(s);
        if(!cnt.count(r))///count()方法返回值是一个整数,1表示有这个元素,0表示没有这个元素。
            cnt[r]=0; ///用来记录出现的次数
        cnt[r]++;
    }
    vector<string> a;
    for(int i=0;i<words.size();i++) ///将每个单词遍历
        if(cnt[repr(words[i])]==1) ///找出只出现一次的
        a.push_back(words[i]); ///将其从末尾插入
    sort(a.begin(),a.end());  ///从小到大排序
    for(int i=0;i<a.size();i++)  ///依次输出
        cout<<a[i]<<endl;
    return 0;
}

参考:紫薯(《算法竞赛入门经典第2版》刘汝佳◎著)

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值