UVA 156 Ananagrams(map,string的理解)

22 篇文章 0 订阅

Ananagrams

Most crossword puzzle fans are used to anagrams--groups of words with the same letters in different orders--for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams, an example is QUIZ.

Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE.

Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be ``rearranged'' at all. The dictionary will contain no more than 1000 words.

Input

Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus tIeD and EdiT are anagrams. The file will be terminated by a line consisting of a single #.

Output

Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always be at least one relative ananagram.

Sample input

ladder came tape soon leader acme RIDE lone Dreis peat
 ScAlE orb  eye  Rides dealer  NotE derail LaCeS  drIed
noel dire Disk mace Rob dries
#

Sample output

Disk
NotE
derail
drIed
eye
ladder
soon

题意:输入一些单词,找出所有满足如下条件的单词:该单词不能通过字母重排,得到输入文本的另外一个单词。在判断是否满足条件时,字母不分大小写,但在输出时应保留输入中的大小写,按字典序进行排序。
思路:先输入单词,(利用vector),先把单词中的大写全部转化成小写,然后把单词中的每个字母都排序一遍,然后放进<map>里进行统计。如果只出现一次就输出。

收获:弱鸡第一次知道,还可以对string直接排序。。,也第一次知道vector可以存string。。。这样字典序就是直接对vector进行排序就行,而且他这题处理的太巧了,求一个字符串不断变换能不能变成另一个,我做最多也是统计两个字符串出现的字母会不会相同,像这样多个要比较的,根本没法做,这题直接把字符串排序,存在map里,这样存完一遍之后,遍历一遍原来的字符串,看他拍完顺序的字符出现过几次,1次就是要求的。。。太强大了

sort(str.begin(),str.end());

#include <iostream>
#include <cstring>
#include <cctype>
#include <vector>
#include <map>
#include <algorithm>
using namespace std;

map<string,int> cnt;
vector<string> words;

string repr(const string& s) //把单词标准化,即大写变小写,排序
{
    string ans=s;  //借用第三方变量进行转换,使最终输出时还能保留大写部分。
    for(int i=0;i<ans.length();i++) ans[i]=tolower(ans[i]); //ps:toupper()是将小写转大写
    sort(ans.begin(),ans.end());
    return ans;
}
int main()
{
    int n=0;string s;
    while(cin>>s)
    {
        if(s[0]=='#') break;
        words.push_back(s); //存入vector
        string r=repr(s);
        if(!cnt.count(r)) cnt[r]=0;
        cnt[r]++;
    }
    vector<string> ans;
    for(int i=0;i<words.size();i++)
        if(cnt[repr(words[i])]==1) ans.push_back(words[i]);
    sort(ans.begin(),ans.end());
    for(int i=0;i<ans.size();i++) cout<<ans[i]<<endl;
    return 0;
}



  • 4
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值