HDU 4135 Co-prime (容斥原理)

Co-prime

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4779    Accepted Submission(s): 1914


Problem Description
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
 

Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10 15) and (1 <=N <= 10 9).
 

Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
 

Sample Input
  
  
2 1 10 2 3 15 5
 

Sample Output
  
  
Case #1: 5 Case #2: 10
Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.
 

Source
 

Recommend
lcy
 


题意:求A-B之间与N互质的数的数量

思路:先求出N的因子,之后使用容斥原理

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

typedef long long ll;

const int MAXN=1e5+5;
int prime[MAXN][10];
int cnt[MAXN];
int factor[MAXN];

int q_factor(ll n)
{
    int num = 0;
    for(ll i = 2; i*i <= n; ++i)
    {
        if(n%i==0)
        {
            while(n%i==0)
            {
                n /= i;
            }
            factor[num++] = i;
        }
    }
    if(n != 1)
        factor[num++] = n;
    return num;
}


ll solve(int m,ll n)
{
    ll res=0;
    for(int i=1;i<(1<<m);i++)
    {
        int num=0;
        for(int j=i;j!=0;j>>=1) num+=j&1;
        int lcm=1;
        for(int j=0;j<m;j++)
        {
            if(i>>j&1)
            {
                lcm=lcm/__gcd(lcm,factor[j])*factor[j];
                if(lcm>n) break;
            }
        }
        if(num%2==0) res-=(ll)(n/lcm);
        else res+=(ll)(n/lcm);
    }
    return res;
}

int main()
{
    int t;
    scanf("%d",&t);
    int casi=1;
    while(t--)
    {
        ll a,b,c;
        scanf("%lld%lld%lld",&a,&b,&c);
        int k=q_factor(c);
        ll ans=b-solve(k,b);
        ans-=a-1-solve(k,a-1);
        printf("Case #%d: %lld\n",casi++,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值