[UVa 1025]A Spy in the Metro

Problem Description

Secret agent Maria was sent to Algorithms City to carry out an especially dangerous mission. After several thrilling events we find her in the first station of Algorithms City Metro, examining the time table. The Algorithms City Metro consists of a single line with trains running both ways, so its time table is not complicated.
Maria has an appointment with a local spy at the last station of Algorithms City Metro. Maria knows that a powerful organization is after her. She also knows that while waiting at a station, she is at great risk of being caught. To hide in a running train is much safer, so she decides to stay in running trains as much as possible, even if this means traveling backward and forward. Maria needs to know a schedule with minimal waiting time at the stations that gets her to the last station in time for her appointment. You must write a program that finds the total waiting time in a best schedule for Maria.
The Algorithms City Metro system has N stations, consecutively numbered from 1 to N. Trains move in both directions: from the first station to the last station and from the last station back to the first station. The time required for a train to travel between two consecutive stations is fixed since all trains move at the same speed. Trains make a very short stop at each station, which you can ignore for simplicity. Since she is a very fast agent, Maria can always change trains at a station even if the trains involved stop in that station at the same time.
这里写图片描述

Input

The input file contains several test cases. Each test case consists of seven lines with information as follows.
Line 1. The integer N (2 ≤ N ≤ 50), which is the number of stations.
Line 2. The integer T (0 ≤ T ≤ 200), which is the time of the appointment.
Line 3. N − 1 integers: t1, t2, … , tN−1 (1 ≤ ti ≤ 20), representing the travel times for the trains between two consecutive stations: t1 represents the travel time between the first two stations, t2 the time between the second and the third station, and so on.
Line 4. The integer M1 (1 ≤ M1 ≤ 50), representing the number of trains departing from the first station.
Line 5. M1 integers: d1, d2, … , dM1 (0 ≤ di ≤ 250 and di < di+1), representing the times at which trains depart from the first station.
Line 6. The integer M2 (1 ≤ M2 ≤ 50), representing the number of trains departing from the N-th station.
Line 7. M2 integers: e1, e2, … , eM2 (0 ≤ ei ≤ 250 and ei < ei+1) representing the times at which trains depart from the N-th station.
The last case is followed by a line containing a single zero.

Output

For each test case, print a line containing the case number (starting with 1) and an integer representing the total waiting time in the stations for a best schedule, or the word ‘impossible’ in case Maria is unable to make the appointment. Use the format of the sample output.

Sample Input

4
55
5 10 15
4
0 5 10 20
4
0 5 10 15
4
18
123
5
0 3 6 10 12
6
0 3 5 7 12 15
2
30
20
1
20
7
1 3 5 7 11 13 17
0

Sample Output

Case Number 1: 5
Case Number 2: 0
Case Number 3: impossible

My Problem Report

这是一道蛮好的记忆化搜索题。相比之前所做的题目,这道题的状态变得更复杂了,转移过程也需要注意很多边界情况。
我的代码也采用了递推方程,但是在递推顺序上与《入门经典》是相反的。其实在开始敲这段代码之前心里也是悬,因为跟书上不一样,担心出错。不过写完之后一次性A了,代码得也不复杂。

My Source Code

//  Created by Chlerry in 2015.
//  Copyright (c) 2015 Chlerry. All rights reserved.
//

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <cstring>
#include <climits>
#include <string>
#include <vector>
#include <cmath>
#include <stack>
#include <queue>
#include <set>
#include <map>
#include <unordered_map>
using namespace std;
#define Size 100000
#define ll long long
#define mk make_pair
#define pb push_back
#define mem(array, x) memset(array,x,sizeof(array))
typedef pair<int,int> P;

bool isr[210][51],isl[210][51];
int  n,d[51],m1,m2,t,input,f[210][51];
int main()
{
    freopen("in.txt","r",stdin);
for(int ca=1;cin>>n && n;ca++)
{
    mem(isl,0),mem(isr,0);
    cin>>t;
    for(int i=1;i<n;i++)
        {cin>>d[i];d[i]+=d[i-1];}
    cin>>m1;
    for(int i=0;i<m1;i++)
    {
        cin>>input;
        for(int j=0;j<n;j++) if(input+d[j]<t)
            isr[input+d[j]][j]=1;
    }
    cin>>m2;
    for(int i=0;i<m2;i++)
    {
        cin>>input;
        for(int j=0;j<n;j++) if(input+d[n-1]-d[j]<t)
            isl[input+d[n-1]-d[j]][j]=1;
    }
    for(int i=1;i<n;i++)
        f[0][i]=INT_MAX/2;
    for(int i=1;i<=t;i++)
        for(int j=0;j<n;j++)
        {
            f[i][j]=f[i-1][j]+1;
            if(j>0 && i>=d[j]-d[j-1] && isr[i-(d[j]-d[j-1])][j-1])
                f[i][j]=min(f[i][j],f[i-(d[j]-d[j-1])][j-1]);
            if(j<n-1 && i>=d[j+1]-d[j] && isl[i-(d[j+1]-d[j])][j+1])
                f[i][j]=min(f[i][j],f[i-(d[j+1]-d[j])][j+1]);
        }
    cout<<"Case Number "<<ca<<": ";
    if(f[t][n-1]>=INT_MAX/2)
        cout<<"impossible\n";
    else
        cout<<f[t][n-1]<<endl;
}
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值