Fibonacci Again

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 40748    Accepted Submission(s): 19521


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
   
   
0 1 2 3 4 5
 

Sample Output
   
   
no no yes no no no
 

Author
Leojay

emmmm...数学题. 用递归暴力会runtime error 其实也心知肚明.. 基本上.. 这么大的数据要巧♂取...

然后列举了f1~10 发现对三取余可能有周期性 周期是8 于是就先把n对8取余 再递归



#include<stdio.h>
int F(int n)
{
	if(n==0)
		return 7;
	if(n==1)
		return 11;
	return F(n-1)+F(n-2);
}

int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		n%=8;
		if(F(n)%3==0)
			printf("yes\n");
		else
			printf("no\n");
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值