poj 3259 Wormholes(判断负环)

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 44782 Accepted: 16496

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

USACO 2006 December Gold


题意:

有n个点,m条普通的双向的路,w条单向的虫洞,问是否能从某个点出发走一些路再回来时回到过去。

即判断是否有负环。


这题的数据很弱,一开始用spfa去判断与点1连通的路中是否有负环,按理应该是wa....结果过了....


题中并没说是连通图,可能与1不连通的一些点也能产生负环。


如果用spfa去判断非连通图中是否有负环应该遍历每个顶点去判断是否有负环, 这样复杂度比较高。


但是Bellman-Ford可以避开这问题,因为Bellman-Ford是去拿每一条边松弛,而spfa只是用与原点连通的边去松弛。


spfa代码:

//C++ TLE, G++ 1000+ms
#include<queue>
#include<cstring>
#include<iostream>
#include<cstdio>
using namespace std;
const int maxn = 50005;
const int INF = 0x3f3f3f3f;
int n, m, w, k, head[maxn], dis[maxn], cnt[maxn];
bool book[maxn];

struct node
{
    int v, w, next;
}edge[maxn];

void addEdge(int u, int v, int w)
{
    edge[k].v = v;
    edge[k].w = w;
    edge[k].next = head[u];
    head[u] = k;
    k++;
}

bool spfa(int u)
{
    memset(book, 0, sizeof(book));
    memset(cnt, 0, sizeof(cnt));
    for(int i = 1; i <= n; i++) dis[i] = INF;
    dis[u] = 0;
    cnt[u]++;
    queue<int> q;
    q.push(u);
    while(!q.empty())
    {
        u = q.front(); q.pop();
        book[u] = 0;
        for(int i = head[u]; i != -1; i = edge[i].next)
        {
            int v = edge[i].v, w = edge[i].w;
            if(dis[u]+w < dis[v])
            {
                dis[v] = dis[u]+w;
                if(!book[v])
                {
                    book[v] = 1;
                    q.push(v);
                    cnt[v]++;
                    if(cnt[v] >= n) return 1;
                }
            }
        }
    }
    return 0;
}

int main(void)
{
    int t;
    cin >> t;
    while(t--)
    {
        memset(head, -1, sizeof(head));
        k = 0;
        scanf("%d%d%d", &n, &m, &w);
        for(int i = 1; i <= m+w; i++)
        {
            int u, v, w;
            scanf("%d%d%d", &u, &v, &w);
            if(i > m) w = -w;
            addEdge(u, v, w);
            if(i <= m) addEdge(v, u, w);
        }
        bool flag = 0;
        for(int i = 1; i <= n; i++)
        {
            if(spfa(i))
            {
                flag = 1;
                break;
            }
        }
        puts(flag ? "YES" : "NO");
    }
    return 0;
}


Bellman-Ford代码:

//47ms
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 50005;
int n, w, m, k, dis[maxn];
struct node
{
    int u, v, w;
    node() {}
    node(int uu, int vv, int ww): u(uu), v(vv), w(ww) {}
}edge[maxn];

bool Bellman_Ford(int s)
{
    for(int i = 1; i <= n; i++) dis[i] = INF;
    dis[s] = 0;
    for(int i = 0; i < n; i++)
    {
        int flag = 1;
        for(int j = 0; j < k; j++)
        {
            int u = edge[j].u;
            int v = edge[j].v;
            int w = edge[j].w;
            if(dis[u]+w < dis[v])
            {
                flag = 0;
                dis[v] = dis[u]+w;
                if(i == n-1) return true;
            }
        }
        if(flag) return false;
    }
    return false;
}

int main(void)
{
    int t;
    cin >> t;
    while(t--)
    {
        k = 0;
        scanf("%d%d%d", &n, &m, &w);
        for(int i = 1; i <= m+w; i++)
        {
            int u, v, w;
            scanf("%d%d%d", &u, &v, &w);
            if(i <= m)
            {
                edge[k++] = node(u, v, w);
                edge[k++] = node(v, u, w);
            }
            else edge[k++] = node(u, v, -w);
        }
        puts(Bellman_Ford(1) ? "YES" : "NO");
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值