poj 2965 The Pilots Brothers' refrigerator

                                                                                                                       The Pilots Brothers' refrigerator
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20362 Accepted: 7844 Special Judge

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4


/*
**实际这个题与1753非常类似,只是在1753代码基础上加上几步处理
*/
#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

bool vis[5][5] = {{false}};
bool flag = false;
int step;
int xx[16],yy[16];

bool Judge()
{
    for(int i=1;i<=4;i++)
    {
        for(int j=1;j<=4;j++)
        {
            if(!vis[i][j])
            return false;
        }
    }
    return true;
}

void Flip(int x,int y)
{
    vis[x][y] = !vis[x][y];
    for(int i=1;i<=4;i++)
    {
        vis[x][i] = !vis[x][i];
        vis[i][y] = !vis[i][y];
    }
}
void DFS(int x,int y,int deep)
{
    if(deep == step)
    {
        flag = Judge();
        return ;
    }
    if(flag || y == 5)
        return ;
    Flip(x,y);
    xx[deep] = x;
    yy[deep] = y;
    if(x < 4)
        DFS(x+1,y,deep+1);
    else
        DFS(1,y+1,deep+1);
    Flip(x,y);
    if(x < 4)
        DFS(x+1,y,deep);
    else
        DFS(1,y+1,deep);
}

int main()
{
 //   freopen("in.txt","r",stdin);
    char ch;
    for(int i=1; i<=4; i++)
    {
        for(int j=1; j<=4; j++)
        {
            cin>>ch;
            if(ch == '-')
                vis[i][j] = true;
        }
    }
    for(step=1; step<=16; step++)
    {
        DFS(1,1,0);
        if(flag)
            break;
    }
    cout<<step<<endl;
    for(int i=0; i<step; i++)
        cout<<xx[i]<<" "<<yy[i]<<endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
基于Django+python编写开发的毕业生就业管理系统支持学生教师角色+db数据库(毕业设计新项目).zip 【备注】 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用!有问题请及时沟通交流。 2、适用人群:计算机相关专业(如计科、信息安全、数据科学与大数据技术、人工智能、通信、物联网、自动化、电子信息等)在校学生、专业老师或者企业员工下载使用。 3、用途:项目具有较高的学习借鉴价值,不仅适用于小白学习入门进阶。也可作为毕设项目、课程设计、大作业、初期项目立项演示等。 4、如果基础还行,或热爱钻研,亦可在此项目代码基础上进行修改添加,实现其他不同功能。 欢迎下载!欢迎交流学习!不清楚的可以私信问我! 基于Django+python编写开发的毕业生就业管理系统支持学生教师角色+db数据库(毕业设计新项目).zip基于Django+python编写开发的毕业生就业管理系统支持学生教师角色+db数据库(毕业设计新项目).zip基于Django+python编写开发的毕业生就业管理系统支持学生教师角色+db数据库(毕业设计新项目).zip基于Django+python编写开发的毕业生就业管理系统支持学生教师角色+db数据库(毕业设计新项目).zip基于Django+python编写开发的毕业生就业管理系统支持学生教师角色+db数据库(毕业设计新项目).zip基于Django+python编写开发的毕业生就业管理系统支持学生教师角色+db数据库(毕业设计新项目).zip基于Django+python编写开发的毕业生就业管理系统支持学生教师角色+db数据库(毕业设计新项目).zip基于Django+python编写开发的毕业生就业管理系统支持学生教师角色+db数据库(毕业设计新项目).zip基于Django+python编写开发的毕业生就业管理系统支持学生教师角色+db数据库(毕业设计新项目).zip
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值