ZOJ 3944 People Counting(模拟+暴力)

People Counting

Time Limit: 2 Seconds Memory Limit: 65536 KB
In a BG (dinner gathering) for ZJU ICPC team, the coaches wanted to count the number of people present at the BG. They did that by having the waitress take a photo for them. Everyone was in the photo and no one was completely blocked. Each person in the photo has the same posture. After some preprocessing, the photo was converted into a H×W character matrix, with the background represented by “.”. Thus a person in this photo is represented by the diagram in the following three lines:
.O.
/|\
(.)
Given the character matrix, the coaches want you to count the number of people in the photo. Note that if someone is partly blocked in the photo, only part of the above diagram will be presented in the character matrix.
Input
There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:
The first contains two integers H, W (1 ≤ H, W ≤ 100) - as described above, followed by H lines, showing the matrix representation of the photo.
Output
For each test case, there should be a single line, containing an integer indicating the number of people from the photo.
Sample Input
2
3 3
.O.
/|\
(.)
3 4
OOO(
/|\
()))
Sample Output
1
4
题目大意:寻找有多少个小人(只出现一部分也属于一个小人)

#include <cmath>
#include <queue>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#define LL long long
#define INF 0x3f3f3f3f
#define RR freopen("D:\\in.txt","r",stdin)
#define WW freopen("D:\\out.txt","w",stdout)

using namespace std;
int n,m;
char Map[110][110];
char Peo[5][5] = {".O.",
                  "/|\\",
                  "(.)"
                 };

bool Judge_in(int x, int y)
{
    if(x >= 1 && x <= n && y >=1 && y <= m)
        return true;
    return false;
}

bool Judge_c(char x, char y)
{
    if(x == '#' || y == '.' || x == y)
        return false;
    return true;
}

bool Judge(int x,  int y)
{
    for(int i=0; i<3; i++)
    {
        for(int j=0; j<3; j++)
        {
            if(Judge_in(x+i, y+j) && Judge_c(Map[i+x][j+y], Peo[i][j]))
            {
                return false;
            }
        }
    }
    return true;
}

void Find(int &x, int &y, char ch)
{
    for(int i=0; i<3; i++)
        for(int j=0; j<3; j++)
            if(ch == Peo[i][j])
                x = i, y = j;
}

int Num()
{
    int ret = 0;
    for(int i=1; i<=n; i++)
    {
        for(int j=1; j<=m; j++)
        {
            if(Map[i][j] != '#' && Map[i][j] != '.')
            {
                int x, y;
                Find(x, y, Map[i][j]);
                x = i - x, y = j - y;
                if(Judge(x, y))
                {
                    ret++;
                    for(int i=0; i<3; i++)
                    {
                        for(int j=0; j<3; j++)
                        {
                            int xx = x + i;
                            int yy = y + j;
                            if(Judge_in(xx, yy) && Peo[i][j] != '.')
                            {
                                Map[xx][yy] = '#';
                            }
                        }
                    }
                }
            }
        }
    }
    return ret;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
        {
            scanf("%s", Map[i]+1);
        }
        int ans = 0, tmp;
        while(tmp = Num())
            ans += tmp;
        printf("%d\n",ans);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值