HDU 5587 Array

Array

                                                              Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
                                                                                  Total Submission(s): 411    Accepted Submission(s): 207

Problem Description
Vicky is a magician who loves math. She has great power in copying and creating.
One day she gets an array {1}。 After that, every day she copies all the numbers in the arrays she has, and puts them into the tail of the array, with a signle '0' to separat.
Vicky wants to make difference. So every number which is made today (include the 0) will be plused by one.
Vicky wonders after 100 days, what is the sum of the first M numbers.
Input
There are multiple test cases.
First line contains a single integer T, means the number of test cases. (1T2103)
Next T line contains, each line contains one interger M. (1M1016)
Output
For each test case,output the answer in a line.
Sample Input
  
  
3 1 3 5
Sample Output
  
  
1 4 7
Source
 首先先把每一次变化后的字符个数与每一次变化后的和分别存放在a[i], sum[i], 然后搜索前n项,如何a[i] == n 说明这个长度恰好是n,sum[n]就是前n想和,否则就找剩下的部分,由于剩下的部分是a[i]一样,并且每一项+1,所以将这些提取出来,转化成前a[i]个,所以可以用之前的继续搜索

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <vector>
#include <map>
#include <list>
#include <cmath>
#include <queue>
#include <stack>
#include <set>
#include <algorithm>
#define LL long long
#define INF 0x3f3f3f3f
#define RR freopen("in.txt","r",stdin)
#define WW freopen("out.txt","w",stdout)
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1

using namespace std;

const LL maxn = 1e16+10;
LL a[1010] = {0, 1}, sum[1010] = {0, 1};

LL DFS(LL n)
{
    if(n == 0)
        return 0;
    int pos;
    for(int i=1; i<=100; i++)
    {
        if(a[i+1] > n)
        {
            pos = i;
            break;
        }
    }
    if(a[pos] == n)
        return sum[pos];
    else
        return sum[pos] + DFS(n-a[pos]-1) + n - a[pos];
}
int main()
{
    for(int i=2; i<=110; i++)
    {
        a[i] = a[i-1] * 2 + 1;
        sum[i] = sum[i-1] * 2 + a[i-1] + 1;
        if(a[i] > maxn)
            break;
    }
    int T;
    scanf("%d",&T);
    while(T--)
    {
        LL n;
        scanf("%lld",&n);
        printf("%lld\n",DFS(n));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值