山东省第一届ACM省赛 G SDUT 2157 Greatest Number(暴力枚举)

6 篇文章 0 订阅
5 篇文章 0 订阅

Greatest Number

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

Saya likes math, because she think math can make her cleverer.
One day, Kudo invited a very simple game:
Given N integers, then the players choose no more than four integers from them (can be repeated) and add them together. Finally, the one whose sum is the largest wins the game. It seems very simple, but there is one more condition: the sum shouldn’t larger than a number M.
Saya is very interest in this game. She says that since the number of integers is finite, we can enumerate all the selecting and find the largest sum. Saya calls the largest sum Greatest Number (GN). After reflecting for a while, Saya declares that she found the GN and shows her answer.
Kudo wants to know whether Saya’s answer is the best, so she comes to you for help.
Can you help her to compute the GN?

输入

The input consists of several test cases.
The first line of input in each test case contains two integers N (0<N≤1000) and M(0
 1000000000), which represent the number of integers and the upper bound.
Each of the next N lines contains the integers. (Not larger than 1000000000)
The last case is followed by a line containing two zeros.

输出

For each case, print the case number (1, 2 …) and the GN.
Your output format should imitate the sample output. Print a blank line after each test case.

示例输入

2 10
100
2

0 0

示例输出

Case 1: 8
由于保证不能大于4个数,所以我们可以转化成两个数,将n个数任意两个两两结合,包括自身与自身以及自身与0

然后问题就转化成从中选两个数了,一个数用来枚举, 另一个则二分查找。

#include <bits/stdc++.h>
using namespace std;
int n,m;
int num[10010];
int a[1000010];
int main()
{
    int cas = 0;
    int n, m, x;
    while(~scanf("%d%d",&n,&m), (n&&m))
    {
        int MAX = 0;
        int top = 0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&x);
            if(x <= m)
                num[top++] = x;
        }
        num[top++] = 0;
        int cnt = 0;
        sort(num, num+top);
        for(int i=0; i<top; i++){
            for(int j=i; j<top; j++){
                if(num[i] + num[j] <= m)
                    a[cnt++] = num[i] + num[j];
            }
        }
        sort(a, a+cnt);
        for(int i=0; i<cnt; i++)
        {
            int xx = m-a[i];
            int pos = lower_bound(a+i,a+cnt,xx)-a;
            if( a[pos] > xx || pos == cnt )
            {
                if(a[pos-1]+a[i] <= m){
                    MAX = max(MAX,a[pos-1]+a[i]);
                }
            }
            else{
                if(a[pos]+a[i] <= m){
                    MAX = max(MAX,a[pos]+a[i]);
                }

            }
        }
        printf("Case %d: %d\n\n",++cas,MAX);
    }
    return 0;
}
 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值