hdu_problem_2052_Picture

题意:输入宽和高,输出一个矩形,并且每次输出完最后要加一个空行

/*
*
*Problem Description
*Give you the width and height of the rectangle,darw it.
*
*
*Input
*Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
*
*
*Output
*For each case,you should draw a rectangle with the width and height giving in the input.
*after each case, you should a blank line.
*
*
*Sample Input
*3 2
*
*
*Sample Output
*+---+
*|   |
*|   |
*+---+
*
*
*Author
*xhd
*
*
*Source
*校庆杯Warm Up
*
*
*Recommend
*linle
*
*/
#include<iostream>
#include<iomanip>
using namespace std;
int main() {
 int col, row;
 while (cin >> col >> row) {
  cout << "+";
  for (int i = 0; i < col; i++) {
   cout << "-";
  }
  cout << "+" << endl;
  for (int i = 0; i < row; i++) {
   cout << "|";
   for (int j = 0; j < col; j++) {
    cout << " ";
   }
   cout << "|" << endl;
  }
  cout << "+";
  for (int i = 0; i < col; i++) {
   cout << "-";
  }
  cout << "+" << endl << endl;
 }
 system("pause");
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值