Picture(HDOJ-2052)

Problem Description

Give you the width and height of the rectangle,darw it.

Input

Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.

Output

For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.

Sample Input

 

3 2

 

Sample Output

 

+---+ | | | | +---+

代码:

#include<stdio.h>
#include<string.h>
int main()
{
	int n,m,i,j;
	char a[1000][1000];
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		for (i=0;i<n+m;i++)
			for (j=0;j<m+n;j++)
				a[i][j]=' ';//先全部打成空格,再变 
		a[1][1]='+';
		a[1][2+n]='+';
		for(j=2;j<n+2;j++)
		{
			a[1][j]='-';
		}
		for(i=1;i<=n+2;i++)
		{
			a[m+2][i]=a[1][i];
		}
		for(j=2;j<m+2;j++)
		{
			a[j][1]='|';
			a[j][n+2]='|';
		}
		for(i=1;i<=m+2;i++)
		{
			for(j=1;j<=n+2;j++)
			{
				printf("%c",a[i][j]);//这是%c,不要写错 
			}
			printf("\n");
		}
		printf("\n");
	}
	return 0;
}


用二维数组稍微麻烦,不用数组或用一维数组也可以做。

#include<string.h>
memset(a,0,sizeof(a));//这是使数组中的数据清零

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值