Picture
Problem Description
Give you the width and height of the rectangle,darw it.
Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.
after each case, you should a blank line.
Sample Input
3 2
Sample Output
+---+ | | | | +---+
#include<stdio.h>
int main()
{
int n,m,i,j;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(i=1;i<=m+2;i++)
{
for(j=1;j<=n+2;j++)
{
if(i==1||i==m+2)
{ for(j=1;j<=n+2;j++)
{
if(j==1||j==n+2) printf("+");
else printf("-");
}
printf("\n");
}
else
{
for(j=1;j<=n+2;j++)
{
if(j==1||j==n+2) printf("|");
else printf(" ");
}
printf("\n");
}
}
}
printf("\n"); //注意此换行
}
return 0;
}