UVa 1587 Box(暴力)

Box

Ivan works at a factory that produces heavy machinery. He has a simple job — he knocks up wooden
boxes of different sizes to pack machinery for delivery to the customers. Each box is a rectangular
parallelepiped. Ivan uses six rectangular wooden pallets to make a box. Each pallet is used for one side
of the box.
Joe delivers pallets for Ivan. Joe is not very smart and often makes mistakes — he brings Ivan
pallets that do not fit together to make a box. But Joe does not trust Ivan. It always takes a lot of
time to explain Joe that he has made a mistake.
Fortunately, Joe adores everything related to computers and sincerely believes that computers never
make mistakes. Ivan has decided to use this for his own advantage. Ivan asks you to write a program
that given sizes of six rectangular pallets tells whether it is possible to make a box out of them.

Input

Input file contains several test cases. Each of them consists of six lines. Each line describes one pallet
and contains two integer numbers w and h (1 ≤ w, h ≤ 10 000) — width and height of the pallet in
millimeters respectively.

Output

For each test case, print one output line. Write a single word ‘POSSIBLE’ to the output file if it is
possible to make a box using six given pallets for its sides. Write a single word ‘IMPOSSIBLE’ if it is not
possible to do so.

Sample Input

1345 2584
2584 683
2584 1345
683 1345
683 1345
2584 683
1234 4567
1234 4567
4567 4321
4322 4567
4321 1234
4321 1234

Sample Output

POSSIBLE
IMPOSSIBLE

这题wrong了N次,气得要死了,想要用各种简单的办法减少循环,结果需要用到结构体、重载、vector等等,知识点又不知道,各种wrong。。。
最后还是用暴力了
等我学到后面再重新写这题吧
在网络上搜了一下,每个人都写得不一样,没个人都写的特别长,看不下去。
不过看到了坤神的代码,确实短,但是很多东西我不知道啊,比方说sort的特殊用法

AC

//UVa 1587
//Jeremy Wu

#include <cstdio>
#include <cstdlib>
using namespace std;

struct face
{
    int len;
    int wid;
} a[6];

int main()
{
    while(~       scanf("%d%d%d%d%d%d%d%d%d%d%d%d",&a[0].len,&a[0].wid,&a[1].len,&a[1].wid,&a[2].len,&a[2].wid,&a[3].len,&a[3].wid,&a[4].len,&a[4].wid,&a[5].len,&a[5].wid))
    {
        for(int i=0; i<6; i++)
        {
            if(a[i].len<a[i].wid)
                swap(a[i].len,a[i].wid);
        }
        int cnt=0;
        int flag=0;
        for(int i=0; i<5; i++)
        {
            for(int j=i+1; j<6; j++)
            {
                if(a[i].wid==a[j].wid&&a[i].len==a[j].len)
                    cnt++;
                else if(a[i].wid==a[j].len||a[i].wid==a[j].wid||a[i].len==a[j].wid||a[i].len==a[j].len)
                    flag++;
            }
        }
//        printf("%d====%d",cnt,flag); 测试哪些是满足构成长方体的
        if(cnt==3&&flag==12||cnt==7&&flag==8||cnt==15&flag==0)//呵呵哒,把所有可能性都算了一遍
            printf("POSSIBLE\n");
        else
            printf("IMPOSSIBLE\n");
    }
    return 0;
}

这题做了三天吧,应该,唉~

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值