统计难题 HDU - 1251 (字典树)

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
Output
对于每个提问,给出以该字符串为前缀的单词的数量.
Sample Input
banana
band
bee
absolute
acm

ba
b
band
abc
Sample Output
2
3
1
0
字典树的入门题,这题用G++交超内存,C++可以A

#include<cstdio>
#include<queue>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
struct node
{
    int countt;
    node *charr[26];
} *root;
void init()
{
    root=new node;
    for(int i=0;i<26;i++)
        root->charr[i]=NULL;
}
void insertt(char* str)//插入
{
    int len,cur;
    node *head=root;
    len=strlen(str);
    for(int i=0;i<len;i++)
    {
        cur =(int)(str[i]-'a');
        if(head->charr[cur]==NULL)
        {
            head->charr[cur]=new node;
            head=head->charr[cur];
            head->countt=1;
            for(int j=0;j<26;j++)
            {
                head->charr[j]=NULL;
            }
        }
        else
        {
            head=head->charr[cur];
            head->countt++;
        }
    }
}
int searchh(char* str)//查询
{
    int len,cur;
    node *head=root;
    len=strlen(str);
    for(int i=0;i<len;i++)
    {
        cur=(int)(str[i]-'a');
        if(head->charr[cur]==NULL)
            return 0;
        else
            head=head->charr[cur];
    }
    return head->countt;
}
int main()
{
    char str[15],que[15];
    int temp,query;
    init();
    while(gets(str)&&strcmp(str,"")!=0)
        insertt(str);
    while(scanf("%s",que)!=-1)
    {
        printf("%d\n",searchh(que));
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值