YAPTCHA HDU - 2973 (威尔逊定理)

The math department has been having problems lately. Due to immense amount of unsolicited automated programs which were crawling across their pages, they decided to put Yet-Another-Public-Turing-Test-to-Tell-Computers-and-Humans-Apart on their webpages. In short, to get access to their scientific papers, one have to prove yourself eligible and worthy, i.e. solve a mathematic riddle.

However, the test turned out difficult for some math PhD students and even for some professors. Therefore, the math department wants to write a helper program which solves this task (it is not irrational, as they are going to make money on selling the program).

The task that is presented to anyone visiting the start page of the math department is as follows: given a natural n, compute

这里写图片描述
where [x] denotes the largest integer not greater than x.
Input
The first line contains the number of queries t (t <= 10^6). Each query consist of one natural number n (1 <= n <= 10^6).
Output
For each n given in the input output the value of Sn.
Sample Input
13
1
2
3
4
5
6
7
8
9
10
100
1000
10000
Sample Output
0
1
1
2
2
2
2
3
3
4
28
207
1609

这个感觉没什么意思,就是关键需要知道一个定理:

(p1)!1(modp),p

所以当 3k+7 为素数时:

(3k+6)!+1=t(3k+7)
(3k+6)!=(t1)(3k+7)+3k+6

所以当 3k+7 为素数时:
[(3k+6)!+13k+7[(3k+6)!3k+7]]=1

反之为0,所以只需要统计哪些数是素数即可。

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstdlib>
#define INF 0x7fffffff
#define N 3000010
using namespace std;
bool prime[N];
int ans[1000005];
void init()
{
    for(int i=2;i<N;i++)
        if(!prime[i])
            for(int j=i+i;j<N;j+=i)
                prime[j]=true;
    for(int i=1;i<=1000000;i++)
    {
        if(!prime[i*3+7])
            ans[i]++;
        ans[i]+=ans[i-1];
    }   
}
int main()
{
    init();
    int t;
    int n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        printf("%d\n",ans[n]);
    }
    return 0;   
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值