HDOJ 2973 YAPTCHA

该博客主要介绍了如何利用威尔逊定理解决HDOJ 2973题目的算法。通过将题设转化为(p-1)! % p = p-1的形式,证明了当p为质数时该等式成立,从而可以通过遍历质数表找到答案。博主给出了具体的代码实现。
摘要由CSDN通过智能技术生成

题目:

YAPTCHA

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 582    Accepted Submission(s): 329


Problem Description
The math department has been having problems lately. Due to immense amount of unsolicited automated programs which were crawling across their pages, they decided to put Yet-Another-Public-Turing-Test-to-Tell-Computers-and-Humans-Apart on their webpages. In short, to get access to their scientific papers, one have to prove yourself eligible and worthy, i.e. solve a mathematic riddle.


However, the test turned out difficult for some math PhD students and even for some professors. Therefore, the math department wants to write a helper program which solves this task (it is not irrational, as they are going to make money on selling the program).

The task that is presented to anyone visiting the start page of the math department is as follows: given a natural n, compute

where [x] denotes the largest integer not greater than x.
 

Input
The first line contains the number of queries t (t <= 10^6). Each query consist of one natural number n (1 <= n <= 10^6).
 

Output
For each n given in the input output the value of Sn.
 

Sample Input
  
  
13 1 2 3 4 5 6 7 8 9 10 100 1000 10000
 

Sample Output
  
  
0 1 1 2 2 2 2 3 3 4 28 207 1609
 

传送门: 点击打开链接

解题思路:

威尔逊定理(链接:点击打开链接)。x/y - [x/y] = (x%y)/y, 可将题中式子化成(3k+6)! / (3k+7)  - [(3k+6)!/(3k+7)] = 3k+6 => (3k+6)!%(3k+7) = (3k+6),另p=3k+7,即 (p-1)! % p = p-1;

=>p是质数,这样我们打个质数表就可以解决问题了。


代码:

#include <cstdio>
#include <cstring>

const int MAXN = 1e6+10;
bool u[3*MAXN];
int prime[3*MAXN], cnt = 0;
int ans[MAXN], t, n;

void init()
{
    memset(u, true, sizeof(u));
    for(int i=2; i<3*MAXN; ++i)
    {
        if(u[i]) prime[cnt++] = i;
        for(int j=0; j<cnt && i*prime[j]<3*MAXN; ++j)
        {
            u[i*prime[j]] = false;
            if(0 == i%prime[j]) break;
        }
    }
    ans[0] = 0;
    for(int i=1; i<MAXN; ++i)
    {
        ans[i] = ans[i-1] + u[3*i+7];
    }
}

int main()
{
    init();
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &n);
        printf("%d\n", ans[n]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值