(pat)A1059. Prime Factors

23 篇文章 0 订阅

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1 * p2^k2 *…*pm^km.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1 * p2^k2 *…*pm^km, where pi’s are prime factors of N in increasing order, and the exponent ki is the number of pi – hence when there is only one pi, ki is 1 and must NOT be printed out.

Sample Input:
97532468
Sample Output:
97532468=2^2*11*17*101*1291

可以当作筛素数的裸题
简单题

#include<iostream>
#include<cstdio>
#include<stack>
#include<algorithm>
#include<queue>
#define maxx 100050
using namespace std;

bool isP[maxx];
vector<int> prime;
void getPrime()
{
    for(int i=2;i<maxx;i++)
    {
        if(!isP[i])
        {
            prime.push_back(i);
            for(long long j=(long long)i*i;j<maxx;j+=i)
                isP[j]=true;
        }
    }
}
int fac[100];
int e[100];
int k;
void getFac(int x)
{
    k=0;
    for(int i=0;(long long)prime[i]*prime[i]<=x;i++)
    {
        if(x%prime[i]==0)
        {
            fac[k]=prime[i];
            while(x%prime[i]==0)
            {
                e[k]++;
                x/=prime[i];
            }
            k++;
        }
    }
    if(x>1)
    {
        fac[k]=x;
        e[k++]=1;
    }
}
int main()
{
    getPrime();
    //cout<<"haha";
    int n;
    scanf("%d",&n);
    if(n==1)
    {
        cout<<1<<"="<<1;
        return 0;
    }
    getFac(n);
    printf("%d=%d",n,fac[0]);
    if(e[0]>1)
        printf("^%d",e[0]);
    for(int i=1;i<k;i++)
    {
     cout<<"*"<<fac[i];
     if(e[i]>1)
        cout<<"^"<<e[i];
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值