1003 Emergency (25 分)
As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.
Input Specification:
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.
Output Specification:
For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.
Sample Input:
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output:
2 4
题型分类:图、单源点最短路径、Dijkstra
题目大意:找出两点之间最短路径的条数,输出最短路径上的最大花费(本题中的花费为救援人数)。
解题思路:用Dijkstra模板即可。
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 510;
const int INF = 0x3f3f3f3f;
int G[maxn][maxn];
int d[maxn], c[maxn], weight[maxn], num[maxn];
bool visited[maxn];
int N, M, st, ed;
void Dijkstra(int s);
int main(int argc, char** argv) {
scanf("%d %d %d %d", &N, &M, &st, &ed);
fill(G[0], G[0] + maxn * maxn, INF);
for(int i = 0; i < N; i++){
scanf("%d", &weight[i]);
}
for(int i = 0; i < M; i++){
int c1, c2, tempW;
scanf("%d %d %d", &c1, &c2, &tempW);
G[c1][c2] = G[c2][c1] = tempW;
}
Dijkstra(st);
printf("%d %d", num[ed], c[ed]);
return 0;
}
void Dijkstra(int s){
fill(d, d + maxn, INF);
d[s] = 0;
c[s] = weight[s];
num[s] = 1;
for(int i = 0; i < N; i++){
int u = -1, min = INF;
for(int j = 0; j < N; j++){
if(d[j] < min && visited[j] == false){
u = j;
min = d[j];
}
}
if(u == -1) return;
visited[u] = true;
for(int v = 0; v < N; v++){
if(visited[v] == false && G[u][v] != INF){
if(d[u] + G[u][v] < d[v]){
d[v] = d[u] + G[u][v];
c[v] = c[u] + weight[v];
num[v] = num[u];
}
else if(d[u] + G[u][v] == d[v]){
num[v] += num[u];
if(c[u] + weight[v] > c[v]){
c[v] = c[u] + weight[v];
}
}
}
}
}
}