day 3

题目1:A - Oil Deposits

  1. 问题描述
    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
    Input
    The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.
    Output
    For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
    Sample Input
    1 1

3 5
@@*
@
@@*
1 8
@@***@
5 5
****@
@@@
@**@
@@@
@
@@**@
0 0
Sample Output
0
1
2
2
2.算法
算法1解题思路
该题判断有多少个连续的油田,@为油田,其中上下左右还有斜方向都是连续的,该题采用了dfs基本算法,对每一个油田进行遍历,同时进行生成图,对遍历的点进行标记
算法1.源代码
#include<bits/stdc++.h>
using namespace std;

int vis[110][110]; //标记
char str[110][110]; //存图

int m,n,ans;

int dx[8]={-1,0,1,-1,1,-1,0,1}; //坐标
int dy[8]={1,1,1,0,0,-1,-1,-1}; //所有可能的点
void DFS(int x,int y)
{
vis[x][y]=1;
if(x<0||x>=m||y<0||y>=n)
return ; //判断是否出界,如果出界直接返回
for(int i=0;i<8;i++)
{
int sx=x+dx[i];
int sy=y+dy[i]; //对可能的八个点进行一一筛选
if(sx>=0&&sx<m&&sy>=0&&sy<n&&vis[sx][sy]0&&str[sx][sy]’@’)
{
DFS(sx,sy); //如果没有出界并且没有遍历过该点并且该点是油田,再次进行访问该点之后可能符合条件的点
}
}

}
int main()
{
while(~scanf("%d%d",&m,&n)&&m)
{
memset(vis,0,sizeof(vis)); //循环一次更新一次
ans=0;
for(int i=0;i<m;i++)
for(int j=0;j<n;j++)
cin>>str[i][j]; //输入图

	for(int i=0;i<m;i++)
	 	for(int j=0;j<n;j++)
			if(str[i][j]=='@'&&vis[i][j]==0)	//寻找符合条件的点 
			{		
				ans++;	//循环一次就找到了一个连续的油田
				DFS(i,j);	
			}
	printf("%d\n",ans);
}
return 0;

}

  1. 总结
    该题灵活的运用了dfs算法,dfs可以对一个图的点进行遍历,去寻找符合条件的点,里面必须有出口。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值