hdu 1867 A + B for you again

A + B for you again

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4661    Accepted Submission(s): 1198


Problem Description
Generally speaking, there are a lot of problems about strings processing. Now you encounter another such problem. If you get two strings, such as “asdf” and “sdfg”, the result of the addition between them is “asdfg”, for “sdf” is the tail substring of “asdf” and the head substring of the “sdfg” . However, the result comes as “asdfghjk”, when you have to add “asdf” and “ghjk” and guarantee the shortest string first, then the minimum lexicographic second, the same rules for other additions.
 

Input
For each case, there are two strings (the chars selected just form ‘a’ to ‘z’) for you, and each length of theirs won’t exceed 10^5 and won’t be empty.
 

Output
Print the ultimate string by the book.
 

Sample Input
  
  
asdf sdfg asdf ghjk
 

Sample Output
  
  
asdfg asdfghjk

题目大意:两个字符串合并成一个,串1的后缀和串2前缀相同部分只出现一次,不固定串1串2,要求合并后串长最小,如果有等串长的两种情况出现,取字典序小的。


解题思路:利用kmp算法的next数组,先将两个字符串守卫相连,若有相同的前缀后缀,减去后缀,交换两个字符串输出,细节见代码。


代码如下:

#include <cstdio>
#include <cstring>
const int maxn=1000010;
char a[maxn],b[maxn];
char s[maxn];
char s1[maxn];
int next[maxn];
int len;
void get_next()
{
    int i=0,j=-1;
    next[0]=-1;
    while(i<len)
    {
        if(j==-1||s[i]==s[j])
        {
            i++;
            j++;
            next[i]=j;
        }
        else
            j=next[j];
    }
}

int main()
{
    int i,cnt1,cnt2,len1,len2,cur,p;
    while(scanf("%s%s",a,b)!=EOF)
    {
        len1=strlen(a);
        len2=strlen(b);
		memset(next,0,sizeof(next));
        cur=0;
        for(i=0;i<len1;i++)   //将两个字符串首尾相连成串s
            s[cur++]=a[i];
        for(i=0;i<len2;i++)
            s[cur++]=b[i];
        len=len1+len2;
        get_next();
        cnt1=next[len];    //求得最长的相同前缀后缀的长度
		if(cnt1>len2) cnt1=len1;     //如果长度大于串2长度,说明整个串1出现在串2 中,因此将减去串1的长度,得到目标串长。

        memset(next,0,sizeof(next));
        cur=0;
        for(i=0;i<len2;i++)  //同理交换串1串2的顺序,目的是找出最大的cnt减去,得到最小串长
            s[cur++]=b[i];
        for(i=0;i<len1;i++)
            s[cur++]=a[i];
        get_next();
        cnt2=next[len];
		if(cnt2>len1) cnt2=len2;
        if(cnt1>cnt2)
        {
            for(i=0;i<len2-cnt1;i++)
                printf("%c",b[i]);
            for(i=0;i<len1;i++)
                printf("%c",a[i]);
            printf("\n");
        }
        else if(cnt1<cnt2)
        {
            for(i=0;i<len1-cnt2;i++)
                printf("%c",a[i]);
            for(i=0;i<len2;i++)
                printf("%c",b[i]);
            printf("\n");
        }
        else    //  判断是否满足字典序条件
        {
            p=0;
            for(i=0;i<len1-cnt2;i++)
                s[i]=a[i];
            cur=len1-cnt2;
            for(i=0;i<len2;i++)
                s[cur++]=b[i];
            
            for(i=0;i<len2-cnt1;i++)
                s1[i]=b[i];
			cur=len2-cnt1;
			for(i=0;i<len1;i++)
				s1[cur++]=a[i];
            for(i=0;i<len;i++)
            {
                if(s[i]>s1[i])break;
                if(s[i]<s1[i])
                {
                    p=1;break;
                }
            }
            if(p)
            {
                for(i=0;i<len-cnt1;i++)
                    printf("%c",s[i]);
                printf("\n");
            }
            else
            {
                for(i=0;i<len-cnt1;i++)
                    printf("%c",s1[i]);
                printf("\n");
            }
        }
    }
    return 0;
}


Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值