poj 1836 Alignment (DP LIS)

Alignment
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 13839 Accepted: 4478

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 
• 2 <= n <= 1000 
• the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

题目链接:http://poj.org/problem?id=1836


题目大意:求数组中最少删除多少个是的任意一个h[i]有h[1]~h[i]单增,或h[i]~h[n]单减。


解题思路:l[i]记录最长上升子序列长度,r[i]记录最长下降子序列长度。而求满足条件的序列长度的式子为( l [ i ] + r [ j ] )


代码如下:

#include <cstdio>
#include <cstring>
double a[1005];
int l[1005],r[1005];
int Max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
	
    int n,i,j,ans;
	scanf("%d",&n);
    for(i=0;i<n;i++)
        scanf("%lf",&a[i]);
    ans=l[0]=r[0]=1;
    for(i=1;i<n;i++)  //单增
    {
		l[i]=1;
        for(j=i-1;j>=0;j--)
        {
            if(a[i]>a[j])
                l[i]=Max(l[i],l[j]+1);
        }
    }
    for(i=n-1;i>=0;i--)  //单减
    {
		r[i]=1;
        for(j=i+1;j<n;j++)
        {
            if(a[i]>a[j])
                r[i]=Max(r[i],r[j]+1);
        }
    }
	for(i=0;i<n-1;i++)
		for(j=i+1;j<n;j++)
		ans=Max(ans,(l[i]+r[j]));
    printf("%d\n", n-ans);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值