1038 Recover the Smallest Number (30)(30 point(s))

1038 Recover the Smallest Number (30)(30 point(s))

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Do not output leading zeros.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

最难的地方应该就是怎么排序吧,刚开始是直接用string默认比较进行排序,发现过不去,原因是 一个string是另一个string的前缀后面多出的部分不能随便进行比较。

所以需要重新设计比较算法,一个string s1和一个string s2所组成的string 最小 那么是s1+s2小还是 s2+s1小,如果s1+s2小 将s1置于s2前面, 如果s2+s1小 将s2置于s1前面

code

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;
void deal(string &s);
bool cmp(const string& s1, const string& s2);
int main() {
	int n;
	cin >> n;
	vector<string> vstr;
	string x;
	while (n--) {
		cin >> x;
		vstr.push_back(x);
	}
	sort(vstr.begin(), vstr.end(),cmp);
	string res;
	bool f = 1;
	for (int i = 0; i < vstr.size(); ++i) {
		if (f) deal(vstr[i]);
		if (vstr[i] != "") f = 0;
		cout << vstr[i];
	}
	if (f) cout << 0 << endl;
	system("pause");
	return 0;
}
void deal(string &s) {
	int idex = 0;
	while (s[idex] == '0') idex++;
	s = s.substr(idex);
}
bool cmp(const string& s1, const string& s2) {
	return s1 + s2 < s2 + s1;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值